All watch faces are gone, other than default ones


As title, now we can’t user any other watchfaces ? WTF!!!


Does anyone see the same issue ?
I could have other watchfaces in my iPhone pebble time app (Latest version), but I can’t have any other watchfaces other than default ones ( one is tictoc, the other one is kickstart) on my Pebble time (Latest version too). It’s quite annoying that I can’t use a watchfaces to see weather, clear digital time at the same time. :frowning:


Same problem. Can’t use other apps and watchfaces.Only TicToc. Iphone SE and Pebble 1. Link to app programmer is dead!!


Same here. Only TicToc which I hate. Any workarounds here?


You have to do a factory reset font know why but it works


Thanks archiehopkins. Factory reset worked for me too.


Factory reset didn’t work for me.
In my app, it says that the watch faces I had before is already added, so I can’t add them again and new watch faces are not compatible with Pebble.

Any suggestions?



When I had this problem I just had to delete my bluetooth settings and pair the watch again. I didn’t have to do a factory reset.


Thank you @archiehopkins, what you suggested works for me.


Factory reset solved the problem. Deteting Bluetooth settings wasn’t enough.


Deleting Bluetooth did not fix it for me. Factory reset did. Thanks​:+1::+1:


WOW… I never upgraded to the latest software (I am one rev. behind) because I heard there was an issue with iPhones. And I love my watchface… so, that you for the warning…now I know that I should not change watchfaces from what I have running. It works fine, I guess, as long as I do not touch my watch or iPhone software.


I’m so sad I’ve lost watch face and numerous other apps. All I did was switch my iPhone off and back on (nothing to do with pebble watch).

Tried forgetting Bluetooth then factory reset but watch faces gone (they say added next to them but aren’t really there) health setting aren’t saving…don’t know what else to try other than asking amazon for a refund!

I really liked the watch and thought I’d get more time using it. Any ideas???


My watch faces and other apps just reappeared. I didn’t do anything.


This has happened to me a couple of times, just uninstall the App and then reinstall it. Once you log back into your account on reinstall you will be all set.

I have found that it seems to happen related to a forced reset on my iPhone.


Just happened to me as well with my Pebble Time on iOS after a reset of my iPhone. The watch was wiped out and the app after account login was devoid of all my watchfaces and apps and settings. Yet, I couldn’t add any of them back as their statuses were already ‘added’. I had to do a Factory Reset of the watch and repairing of Bluetooth and firmware update and at that point, both the app and the watch seemed to be more or less back the state before the reset (exceptions being on some of the watch settings like backlight, vibrate, etc.). A reboot test of my iPhone did not create the problem again.

Beginning of the end, I suspect… Fibbit will have to do something pretty amazing to earn my business back.


I did a factory reset and nothing changed. Then the watch rebooted and reset itself. On reboot, it went thru the setup with the phone app and everything is back ON THE PHONE only. The watch is still bare. I can add new stuff from the app/watchface stores in the phone app, but none of the existing stuff gets transferred to the watch. Very frustrating as I actually enjoy using the Pebble more than the Apple watch. I hope someone has a solution to this.


The issue seems to come up on a iPhone reset. I have found a couple of things that help to avoid the problem (two weeks so far with no issues). First, if at all possible, I make sure the watch is turned off before the phone boots back up. Second, if I get a message on the phone/watch that Pebble has found a new watch, I immediately reboot the phone again, and while that is happening, I turn off the watch.

Much better than factory reset, which gets rid of several custom alarms. The bluetooth reset has always worked for me as well, but you have to be sure to forget both on the watch, and on the phone (both regular and LE). A pain if you have to reboot your phone a lot (and I have battery issues so it happens when I’m not paying attention), but this eases it a bit.

Note also, if you have not updated to the lastest firmware (which came out just before the merger was announced, consider doing so. It seemed to have helped somewhat. -John


Same thing happened to me, and at a most inopportune time…
Tried rebooting both iPhone & Pebble
Then told both devices to forget each other

FINALLY, after a factory reset, all was back to normal; the Pebble App restored all of my saved WatchFaces, and the settings were all there. Not sure if I should have just tried the factory reset first…

BIG PITA, though, I wasted over an hour on this.

FWIIW, this happened about a month or two ago, nearly identical issue & resolution.


Not having this problem