Android - Pairing Troubleshooting


#1

If you have already paired Pebble with one or more devices, your attempts to connect on your Android may be blocked by a previous pairing trying to re-connect or if a severed connection did not fully register on one of the devices. Please unpair / forget the pairing from each device.

To unpair devices, follow this path on your Pebble:

Main menu >> Settings >> Bluetooth >> [Device’s name] >> Forget

To unpair Pebbles on your Android devices, go to:

Settings >> Wireless & Networks >> Bluetooth >> hold on [Pebble’s identifier] >> Unpair.

​To make sure that your previous connection has been fully severed, please restart each device. To reboot Pebble, please press and hold the Back and Select (simultaneously) for 10-seconds.

Once you have successfully unpaired and restarted each involved device, try your pairing again.

Launch your Pebble app and then “Tap to connect your Pebble” at the bottom of your screen to start the pairing walk-through.

  • Make sure that you Pebble is turned on and nearby.
  • Your Pebble app will automatically look for and list available Pebbles. When you see your Pebble’s identifier listed, tap it to pair.
  • Confirm on your Android and on the Pebble itself that you would like these two devices paired.

Hit the back button twice on your Android to return to the app’s main screen.

If your Android device is still not pairing or connecting, please double check that the settings are correct and BT is turned on.

For Pebble, the path is:

Main Menu >> Settings >> Bluetooth, and make sure that it is showing “On”.

From the home screen on your Android device, go to:

Settings >> Wireless & Networks and make sure that Bluetooth is showing “On”.

Then use your back button to go to Accessibility and make sure that the Pebble option is checked.

If those settings were correct and you still cannot connect to Pebble, please un-install your Pebble app and re-download it. Make sure that the settings listed above are still enabled, and try your pairing again.

Then use your back button to go to Accessibility and make sure that the Pebble option is checked.


#2

Solution: Here’s what got my Pebble Time Round to pair with my ANDROID phone after watch was stuck in recovery mode after factory reset. I thought I had tried EVERYTHING, but I guess I hadn’t because this worked:

  1. On Android phone: I went to settings, then to accounts, and then I deleted the Pebble ACCOUNT. Then I uninstalled the Pebble and Android Wear apps.

  2. On my Pebble Time Round, I did my 100th unsuccessful reboot, and then I forced a SHUT DOWN (as opposed to a reboot) by pressing the back button for 10 seconds.

  3. Then I restarted my phone and reinstalled the Pebble and Android Wear apps (but didn’t open the Android Wear app), and logged in to my Pebble account.

  4. Then I turned on the Pebble, and found things working well enough that I could attempt pairing again! This time I began trying to pair via bluetooth rather than the Pebble app, and I started by trying to pair with the Pebble which had an LE in the bluetooth name. As before, on the phone it appeared to have successfully paired but the watch stayed locked up. But then I tried double-pairing - I tried to pair the phone with the non-LE bluetooth after half-pairing it via the LE bluetooth. And that worked! The watch starting updating the software and it’s a watch again. I hope this helps someone!


#3

Can we use it with spy apps on Android?