Any fix for fe504502?


I got a classic Pebble and turned it on… Nothing happened. So I plugged it in and got a sad face and an error code of “fe504502” and a link to I tried the steps, and contacted Pebble support. They couldn’t help. Any tips?


The 502 error indicates a bad firmware flash. You should be able to reinstall the firmware by holding the back, up and middle buttons for ~45 seconds until the watch vibrates. Don’t let go of the buttons until the watch vibrates, even if the watch reboots.

Once the watch vibrates it should go back to the pairing screen it displayed the first time you turned it on. Pair it with our phone and Pebble app and it will reinstall the latest firmware.

If you can’t get out of the SOS screen, hold the Down button for 20 seconds or so and it should exit. Then do the down, up and select thing.


I left the watch overnight and the battery drained. I plugged it in and it kept flashing between the battery charging screen and the pebble logo. I tried doing the button combination and it came up with a loading bar, and then it went back to the battery charging screen, even though it wasn’t plugged in. So I plugged it in again and it came up with the error again. No keys work.


Hi. I get the same code, flashing when charging and unresponsive buttons. Did you get a fix for yours?