Battery+ losing runtime


Over the last month or so I’ve noticed that Battery+ loses the run time. Remaining time is fine, but I’m unable to see when the watch was last charged. I’ve tried deleting and reinstalling the app but it makes no difference. The watch is fine because I can see from the uptime it hasn’t reset. Anyone got any ideas?


I have the same problem since months now, I couldn’t figure out a solution yet :frowning:


Ok, not great news but at least we both know one other person with the same problem! I did try e-mailing the developer yesterday but no response so far.


I am also interested in solving this problem. But I doubt the dev will do anything. I believe the problem is with the watch firmware, as it periodically purge apps from memory and this is what’s causing losing stats. It started with 4.3 firmware and I doubt we will get an update on the watch firmware anymore.


I have noticed this happen, but it has always happened to me after the Pebble crashes and has to reset itself. At that point, Battery+ forgets hour long the watch has been running and just displays "- - " instead.

For me, the crashes seem to mostly happen with alarm timers. If I add a new timer and change the time around, sometimes the alarms won’t activate & the watch will crash at that exact time instead. Seems there’s an off-by-one bug in there somewhere.


To me it happens also without any crash of the Pebble, I don’t know what is the cause.


Same problem here. Battery+ stopped recording historical data and now only shows the current battery level.

It no longer shows time remaining, run time, charges, run time and max life charts, the record or percent charts.

The most irritating thing is the Battery+ Push Pins keeps popping up and taking me out of my current app and back to the watchface.

I haven’t tried a reinstall yet, but the watch has been rebooted several times. I also confirmed Battery+ is selected as a background app and have tried toggling it off/on.


You can Buy Some pebble Battery


please, do not spam this thread


That’s Was a Not spam It was a Suggestion


How is it a suggestion? The problem is with an app, not the battery.

Back on topic, this is pretty disappointing. How hard can it be for the app to record when the battery was last charged? I’m sure this information is on the watch, the app just needs an update to access it, but I guess no more updates. :frowning:


I Think You Are Right Will

From Next Time I will First Read The The Content Too

Thanks For Reply


I’ve had my pebble steel for a week now and battery+ has just shown “-,-” for the duration


You don’t miss what you never had!