Display Issues | Screen tearing | Graphic glitches - File Support Request via Pebble App!


#1

In the last week, my Pebble has begun showing the screen tearing. Usually it happens when a notification shows up on my watch. I look down and sometimes it’s not even readable. Usually pressing a few buttons clears the problem and everything is fine. For a while. I searched the forums and found some discussion regarding beta software but that’s not my issue. I removed all the additional watch apps I had loaded on the watch but it still does it. I’ve tried resetting but that hasn’t helped either. In excellent condition and no trauma to watch. I was part of the first wave of supporters to get the watch but don’t remember the exact date. Thanks.


Randy

#2

Hello,

I have the same problem. It gradually started about a month after I got the watch.
First, it would happen only once a week and only with scrolling in menus and would intermediately go away with simple change of watch face. Over time however, the problem got worse and now it’s broken all the time and I rarely see a clean screen. It even happens on the Update screen after Factory reset.

It’s really bad and the watch is unusable as you can’t read time 90% of the time.

I put an unlisted video on YouTube … http://www.youtube.com/watch?v=12m0xPeMU7o



#3

The screen of mine is completly blank, the watch seems to work when go through the menu to shut it down (remembering the steps to get there) because it shut down as expected, but I see nothing at all on the screen, it started like everyone, some lines and pixels but 10-15 minutes later the screen died :frowning:


#4

I’ve had mine since early March. I believe that the screen garble on my watch is directly affected by the firmware. It ran beautifully as it was delivered. One month later the firmware was updated and I began to see artifacts across the screen periodically that was easily fixed with the 3 button fix. I updated the firmware whenever it was available. 1.11.1 that caused others problems actually removed any screen issues for me. With this latest firmware, 1.12.1, I have the clock issues, not losing time but actually just freezing. Time zones change and syncing with the phone posed some challenges also. The watch time only updated when it polled the phone. Then the screen became a significant issue. 3 buttons don’t do much for it but it would sometimes, blink and correct itself. I tried the normal fixes, removing the app, flashing the firmware etc. It did well for two days and then went back to major lines misaligned information rendering the Pebble useless. I do not believe that this is broken connection to the display as stated in other “screen issues”. I say this because I can go into a setting screen and shake the hell out of it and not one line will appear and it keep time etc. I am no longer able to get into recovery mode so until new firmware is released, my Pebble will be inactive.


#5

Whoa whoa whoa @whacko hold on there a second! I remember back in the good old days when you used to tell people a possible solution and not just refer them to the trail of tears that may lead to an RMA several weeks later (pebble support). Ok now to your problem. Try booting your pebble in recovery mode. (I think that’s what it’s called) hold down the left, right center and upper right button for about 30 seconds. Your pebble will reboot multiple times. DONT LET GO. When you feel the pebble vibrate you have entered recovery mode! You will need to download the latest software again from the pebble app. After you have done all this, if you still get the screen distortion then file for an RMA. I had the same issue. Recovery mode fixed the watch for a few days before it started up again. I ended up filing for a replacement which I got 1.5 months later. So see if it works. Good luck!


#6

Same problem as discussed above. Out of the box it worked for 5 minutes and then as you moved through the screens the horizontal lines appeared and after 15 minutes the watch was unusable. Charged it for 6 hours, rebooted it, downloaded latest software but still the screen is unreadable. Very dissapointing as I see so many others have had the same problem. I think Pebble need a better quality assurance processes.


#7

I have the same problem and I am in the middle getting it replaced. Mine took a 3-4 months to start doing it. I am not happy that it won’t be replaced with a Kickstarter edition. I was one of the first 200 or probably 100 people to back the pebble. Now I will never have a Kickstarter edition once its replaced.


#8

Same problem here, tried everything but nothing works. I also had a “bricked” Pebble so this is my second dead watch. Waiting for Support to respond, very disappointed.


#9

Completely bricked, wow.


My wife’s is also a kickstarter edition and its been okay but the battery life isn’t as good as mine. I hope that my replacement has as good battery life as mine.

Also I gave the watches as wedding gifts for us. Too bad I have to get them replaced.

#10

Thank you for that, @eyeis. I’m having the same problem as the OP, and that seems to have cleared it up for the moment. I hope that’s the last of it—it was weird; my Pebble has been working just fine for months, and all of a sudden, glitches.


#11

I got my Pebble replaced (RMA) - however I see it has the same HW&SW version as the previous one. So I am not happy because I expect to see the same issues in a few months…


#12

how long did it take to replace your pebble since you filed your RMA?


#13
Pawel N said:
I got my Pebble replaced (RMA) - however I see it has the same HW&SW version as the previous one. So I am not happy because I expect to see the same issues in a few months...

That has nothing to do with it. The newer hardware revision was simply a manufacturing update and the software/firmware needs to be updated to the latest regardless and doesn’t affect this problem.


#14

Got this problem on my daughters orange pebble now… the watch is 2 weeks old :frowning:


Got my own pebble replaced after it died completely.
So, this is the second pebble out of 3 with problem… wonder how long my wife’s pebble will survive

#15
MartinJuhasz said:
how long did it take to replace your pebble since you filed your RMA?

It was very quick :slight_smile:
RMA request was filled and sent on Nov 9th. On 22th I received my new Pebble (including 2 days of delay because of customs).


#16

I’m having the same problem also. I have reloaded software many times and many different versions. Mine is Kickstarter also. I have sent in picture and now in the long wait for support to reply back. Seems to me support should be working 18 hours a day 7 days a week until they get rid of the support backlog.


#17
GeneKendrick said:
support should be working 18 hours a day 7 days a week until they get rid of the support backlog.

Don’t you feel like a dick when you write something like that? I mean do you really feel that way? What an astounding sense of entitlement and self worth you have then - that you think people should be working over time and stay away from their families, to make YOU happy and meet YOUR expectations.

Did you contact support thru the pebble app on your phone? Did you get an auto reply right away? If not, you probably didn’t email the right address either.


#18

No. I don’t feel like a dick for writing that, no more than you feel like an asshole for that replay. I sent through the Peeble app on the iPhone and I did suggestions in this forum. Yes I think they should work overtime to correct the problem not just let the problem continue. I was a manager and my people and myself work 18 hours a day and 7 days a week many times to clear up backlogs. I would not have said it had I not done it. Peeble is a great product, but they are getting a bad reputation for poor service. It is going to be hard to compete on the product alone.


#19

I can’t get my Pebble out of Recovery Mode pair w/PHONE( it SAYS) .This happens when I try to update it . I try to pair it with my APPLE and it does NOT work . I have my PeBBLE since OCTOBER !! I emailed SUPPORT no response ,Someone Should start a class action suit .DEFECTIVE PRODUCT !!!


#20

I have the same issue, i recieved my pebble watch yesterday and it started to display lines on the screen. It has become very bad and i cant even read the time.