Factory reset problem


Hi all,
After factory reset I can not use my pebble watch. It seems there is a connection problem; I got “Make sure “Pebble 36D4” is turned on and in range” warning on my mobile phone. But I can not use any functionality on watch, below you can see watch screen. Any advice to fix it?? To hold 2 buttons(left top+right middle) in a few seconds didn’t help to overcome.
My phone is Iphone6 and bluetooth is on status.


I faced the same issue, Just un-pair the watch from all your device, uninstall the pebble apps from you phone and Start fresh. Hope it helps


It is OK now:) Thank you very much kchinnasamy.


The same thing happened to me today. I also had a Pebble Steel and wanted to add it to my iPhone 6.

The Pebble app on the iPhone 6 would not even let me sync the two via bluetooth. I would hit the pairing check mark on the Pebble Steel, but there was not response.

I finally went away for a few hours, and when I came back, I tried it again. This time it worked. I was able to sync via bluetooth and download the latest firmware.

I think, this time, there was a glitch with the Pebble Servers or something. This is because I had another problem at the same time on my Pebble Classic and Pebble Time. I could not longer more than the Tic Toc watch face, and the kickstarter watch face. Nothing else was available literally!

When I came back a few hours later, I had to reset both to factory reset, and re-sync and install the firmware. Then everything was fine again, including all the watch faces that had disappeared.

However, I think this is all a taste of what will happen once the Pebble Servers go away. No way to download firmware, after factory reset. No access to watch faces other than Tic Toc. No apps other than Calendar, because that was the only app left on my Pebble watches during the glitch.

Glad everything seems to be back to normal for now.


Good Morning,

need some help too

I have a Pebble 2 . Battery start playing & even won’t last for my 10K run . I’ve done the factory Re set wont pair, unpair from my all devise’s wont pair, delete the Pebble App & re downloaded still not pairing :frowning: