FIXED: Screen tearing: memory leaks and battery level?


#1

Screen tearing issues as a consequence of faulty connectors have been extensively “done” on the forum, and it appears Pebble readily replaces watches with these issues.

However, I notice occasional screen tearing, which always dissapears if I change watchface or - if neccesary - reboot the Pebble. I have noticed that when I have these occasional issues, memory is almost always low on my iPhone (as determined by the “Battery” app), or the battery on the Pebble is low, or I have been using a bluetooth-intensive app such as iSmoothRun - or a combination of these possible factors. I find rebooting my Pebble and iPhone every Monday morning before work keeps the tearing symptoms at bay.

I wonder if some of the observed tearing issues are a result of memory leaks and battery level?Has anyone had a similar experience?


Screen is unreadable when receiving notifications
#2

Screen tearing. Ok, now their is a name to my issue.

Yeah, this has been a pretty big issue for me lately and is making the watch unusable. Started a run yesterday with RunKeeper and the screen just gets distorted and unreadable.

A shut down does not seem to make a difference.

Hoping this is a software and not a hardware issue as my pebble was just replaced due to a bad accelerometer.

Please post back if you find out any more info on this. I am going to submit a support request as well.

Thanks, Rick


#3

This is something you need to contact support about and an RMA may need to be initiated.


Big disappointment in pebble classic it is a LEMON not a whatch
#4

Tearing issue fixed - the issue seems to be “connected” to a rubber-mounted screen connector, which developes a faulty connection over time, and which may be exacerbated by heat.


Over the past weeks I have experienced excessive screen tearing, multiple times a day. Ten minutes using a thin cardboard shim and a dab of silicone grease for the seal and: 24 hours - and counting- of uninterupted clear screen. Cut the shim so the small brass nub is not covered, and use a glue stick to fix the shim.

Note: this will void your warranty. However, it is a simple fix, and greasing the seal while ensuring it is correctly seated when fitting will ensure water resistance (source: I have serviced and repaired many dive watches).



#5

Wow, nice job, that is pretty interesting. Though, a little too risky for myself to perform. Going the RMA route instead.


#6

At 48 hours and counting: not a single tearing issue to report! This is probably completely coincidental, but I have zero BT unpairing issues in the same period…


#7

At 6 days and counting: not a single tearing issue to report!


#8

What size tool did you use to remove the back. It looks like a torx.


#9

Never mind. I used a #3 tor and it worked like a charm! No problems with my Pebble.


#10

Did it with mine to! Works pretty nice. Don’t you think vibration is less strenght?


#11

Can you guys tell me if how thick or how thin is the cardboard used? And will any silicon grease work? I’m having the same issue.


#12

Will a piece of an old credit card work to make pressure??

I will do this because i RMA´d it, but got to keep the damaged one…so i have nothing to loose


#13

Well, i did it…and it worked!!! Immediately after puting the screws on the pebble again, no more tearing!

This means my current pebble will go to my wife when the RMA arrives, and it will work fine :slight_smile:


#14

Anyone know how to take the original pebble apart for this fix? I don’t see any screws.


#15

@Rod only the current models are held together by screws. The earlier versions (including Kickstarter ones) are sealed and there’s nothing you can do to access the internals short of breaking it apart.


#16

And… 3 months without a single issue.


#17

i’m going to have to try this on my pebble… these corrupted screens are getting quite annoying especially when i need to know the time

i’ve already contacted support and they are sending me another one (it’ll be the third one… ugh)… so i won’t be sad if i accidentally kill this one in the process of trying your fix


#18

alright… just did it… so far so good…

my usual attempts to corrupt it (randomly press buttons, sending notifications, staring at it) didn’t work… so i guess it’s fixed for now!! yay

pictures here:



#19

It works no doubt, haven´t had a SINGLE issue since i did the fix


#20

update: so far so good… went the whole day without a corruption! hope this is a permanent fix!!