Having troubles pairing Pebble Round with iPhone 7


So I’ve had my pebble for a while but haven’t used it since my old phone (an old iPhone 6 that I no longer have) and just picked it up and wanted to pair it with my new phone. However, whenever I try to pair, it gets to the part where I can have both devices accept the connection and then the watch shows a screen with a big red stop sign with an x in it. I factory reset it and reinstalled the app and I’m still getting the same problem. I’m hoping it’s not unusable but it’s not looking good. Any advice?

Heres the screen for reference


Yes most of the time the issue for connectivity is because of iOS 11. If there is a way you should probably downgrade.


Have you deleted the pairing of your Pebble with the iPhone 6? On your watch, go to Settings > Bluetooth and delete the pairing.


Yeah I deleted it and that didn’t work. So then I factory reset it and that didn’t work either :confused:


first, unpair your mobile…go to the setting of the Bluetooth and unpair the iPhone…after checking the connectivity of your phone…because many time happen that the issues arise because of iOS…hitachi customer service providing technical support service


Right I factory reset it so I don’t have the ability to go into any settings. It is completely wiped. No pairing information is left on because it is back to factory defaults.


I’m using my iphone 6s iOS 11.2.2 with PTR and it works fine.
Make sure PTR has the latest firmware.
Remove/“forget” the bluetooth pairing on the iPhone and on the PTR.
Reset both the iPhone and the PTR, and try again.
It ought to work.

I had problems like this before, but these worked for me:

I tried to pair a new iPhone 6s Plus with Pebble Time Steel and got the Recovery Mode Loop.
About half a day later, this worked for me:

  1. installed Pebble Time app
  2. Remove all Bluetooth connections on my iPhone
  3. Turn off Bluetooth
  4. Restart my iPhone
  5. While iPhone is restarting, reset my Pebble (press Left, Top Right, Middle Right buttons all at once)
  6. After iPhone restart, start with the Pebble app (not Settings) to connect to Pebble
  7. Select Pebble Time Round
  8. It finally updated my Pebble Firmware, and took a long time reconnecting

Help! Pebble Time displays “getpebble.com/app”. Totally nonfunctional. Unable to pair. No support

Steve1 on Jan 16, 2017

Just for laughs I enabled my standby mode on my steel; it consistently disconnected itself from my iphone every five minutes or so even though it was on my wrist.
Now that I’ve disabled the mode BT has once again become reliable.
Not sure if this is germane to the newer series of watches.