iOS Update Bluetooth issue


Updated to iOS 11 last week and noticed my watch wasn’t working properly. I repaired the devices, still no fix. I forgot both the phone and watch on each device, and couldn’t pair them back up. I have reset the watch, deleted the app and restarted both, now my phone cannot find the accessory. Any suggestions? TIA


I feel your pain, Brian! I’m in the same boat. I hope someone can help with this issue.


Same problem. Reset the Bluetooth, restarted the apps: no go. Then I discovered that I still had the Apple Watch app on my phone, which I deleted. That worked for me.

Update - more stable on ioS 11,2 but the watch sometimes needs a manual reconnection after the pebble has been on charge. Like Patricia North below, I forget the Bluetooth connections to the watch, forget the phone from the watch, turn off the phone’s bluetooth, close the pebble app, restart the phone’s bluetooth, and open the pebble app.


I tried deleting the watch app also, no luck. Anyone else having this type of issue?


I found the easiest way to reconnect my pebble is to reboot the iPhone. When it restarts just open the pebble app and the blue tooth symbol reappears and up to 11.1.1 the watch has reconnected every time. No factory restarts, very easy.


Hi, I have had loads of the same problems,and its driving me nuts,but I have found a quick help on the constant bluetooth connection problem, double click the home button and the apps that are in use come up, scroll sideways and find pebble flick the app up and that kills it and closes it off and 9 times out of 10 it reconnects straight away and stays for most of the days and sometimes longer ,sometimes it will take to goes but its much easier that forget and trying re-pair and it works with both my classic and time so it should work with the rest, ,fingers crossed it does the same for you folks this works with 11/11.1/11.2
and has done for the last 14 days ,I have just reconnected it now in 20 seconds so it should work on most ipones as I tried it on a 5s and a 6 and the same good result


I just bought the round last week. Yesterday, I switched my phone from an iPhone 6 to a 6S. I didn’t really have any issues with the BT working on my old phone, but I’ve had a helluva time getting it to work with my “new” phone. I got it to pair after wanting to give up several times. But as I wake this morning, it’s not paired (randomly unpaired in the middle of the night on its own).

Now my issue is, my phone says it’s connected. The watch says it’s on and, I THINK, it’s connected. But the app, not so much. I have deleted the Apple watch app. I’ve rebooted and restarted and everything else that I can do. EXCEPT delete and re-download the app.

Funny thing, when the pairing fails, it asks if I want tech support. I open the link and it’s a blank page. Thanks for the help Pebble :roll_eyes:

Does anyone have any suggestions? I haven’t updated my iOS to the 11.2 yet. Do you think that might help?


I had the issue with WiFi after upgrading my iPhone 7 to iOS 11.

I also make a downgrade to iOS 10 and nothing happened, The only place where my WiFi is working in the Apple Store and MacDonald.

But after searching a lot on the web I found this solution and its worked for me. Now It’s Solved!


If you go into setting Bluetooth on your iPhone and reset network connections. After the phone restarts reopen the pebble app and the phone reconnect… I just did a iOS update to ios11.2 as of December 4/17 the pebbles reconnected immediately and after 2 days the bet connect is solid. Maybe apple finally fixed the Bluetooth problems and iOS 11. Your watch not the problem iOS 11 is the proble,


Don I have tried that previously and tried again this morning. No success. I even deleted the app, and downloaded again. No success. I’m starting to think it may be a problem with the watch itself. Maybe I have it frozen???

When I power the watch on I can see the Bluetooth code, but the phone and app never recognize it.


IOS 11.2 is out. Might try updating to see if it fixes the problem.


Are you going to general, reset, reset network connection, than possible hold power and home button down until the phone reboots.
Than reopen the app and mine syncs up immediately.
Questions one are you working with an iPhone
Question two, have you rebooted your watch if so this may be your trouble
Question three are you using the black pebbles app if so that the one you want
Reset the watch, go on google search, Pebble watch reboot. it may help.
Says to hold the left button and centre and top right buttons until watch is a reboot ed this is not a restart.


I have a pebble time paired with an iPhone 6s running IOS 11.2.1. Since IOS 11 came out I’ve had to randomly go into the phone settings, go to Bluetooth and switch Bluetooth off and on again. Watch to make sure both the pebble connections re connect (incidentally they usually say they’re connected before I switch off then on again) This makes mine work again.


I just updated to iOS 11.2.1 and constantly lose Bluetooth connection. Frustrating. Any fix? I called Apple tonight and received no help.


Try IOS 11.2.2. That fixed my issues with voice related apps like Send Text, Snowy, and Voice Note.


Yes, seems to be working better.