Notifications not received on Huawei P8 Lite


#1

Hello all. My girlfriend has a Pebble Time, and when she had a Motorola Moto E the Pebble worked flawlessly, steadily forwarding every notifications. Now she has a Huawei P8 Lite, but she can’t see any notifications anymore. The phone receives all the notifications, but somehow it won’t forward them to the Pebble. I already tried to reset the Pebble but nothing changed; the only notification she sees are the missed calls (but nit the call itself when it’s incoming) and the Pebble Health notifications. I also marked the Pebble app to stay active during standby on the phone, but that didn’t help either. What can I do?


#2

Try installing Notification Center.


#3

You mean this app? Then why it worked with the Moto E without this app?


#4

Has she gone into the phone’s accessibility menu and enabled the Pebble accessibility service? Some versions of Android require the accessibility service to be enabled in order for the watch to get notifications from 3rd party apps.

https://help.getpebble.com/customer/portal/articles/1774386

Have she filed an official Support Request via the Pebble app? This will send Pebble Support usage logs that might help them identify the cause of the issue you are experiencing.


#5

This is one funny thing. It seems that, somehow, in the P8 Lite build are two separate places for the Accessibility service. I managed to enable them both, even if the “standard” accessibility settings page I’m used to was really hidden and I only could find it via the Android Wear app…

However, I’ll file an official support request. Thanks.


#6

Yes, that app. I don’t know why you’re having problems. Just throwing out ideas.


#7

I managed to get it to work after messing around with the setting for ages.

  • Make sure Pebble app is “ignored” form optimisation.
  • Make sure Bluetooth visibility is set to never time out.
  • Disable the feature that closes apps once the screen is turned off for ALL apps.
  • If it’s still not working then try and hold down on the up, select and back button all at once.

Hope this helps.


#8

Gracias, a mí me sirvió esta.
Desisntalé y reinstalé la app, pero no desconecté bloothoot.
Desinstalar, instalar, desconectar Bthoot, conectar y parece que funciona.