Pebble 2 - constantly having to re-pair


#1

My wifes Pebble 2 (Christmas gift) drops BT pairing every single day. We’ve been through the process of reconnecting it (forgetting the device and then reconnecting); but now it’s getting stupid. Her previous pebble didn’t need to do this. We’re at the point that we’re thinking about returning it for a refund as it’s obviously not right.

Iphone is on the latest version of IOS, as is the Pebble 2.

When we open the Pebble App - it shows as if it’s not connected but if I look in Bluetooth devices it’s showing as connected. Bring the watch near the device and it says connected and that I should clikc on the top right button - but the top right button is not activated.

The only way to get it to do something is to forget the device on the phone and go through the resync process. We learned not to reset the watch as that deletes all the date it’s captured.

Any suggestions before I return it as faulty ?

Cheers


#2

Have you tried closing all background apps on iPhone, and restarting the iPhone?


#3

Hello Smudge – If, when you bring the watch close to the phone, it says to press the top right button on the watch – YOU MUST DO THIS. I am not sure why you would think the “button is not activated” but this step is required to complete the pairing process. I have found that when they say “close” they REALLY MEAN CLOSE!!! I typically put my watch, face up, ON TOP of my 6 SE screen during this process. When you do this properly and successfully, your PHONE will reply that the “pairing” was successful!. Another tip, I have found that “restarting” the phone periodically helps to straiten out issues with pairing.

Also don’t forget to “FORGET” at both ends… both the watch and the phone. When I get frustrated. I usually do this.

  1. Kill the Pebble App on the phone.
  2. Go to Settings/Bluetooth and disconnect the watch from the phone.
  3. Forget the watch on the phone.
  4. Power Down the phone.

While the phone is powering down…

  1. On the watch go to settings/bluetooth

  2. Disconnect the BT to phone (this should already be disconnected)

  3. FORGET THE PHONE!

  4. Start Up the Phone.

  5. Restart the Pebble App on the Phone

  6. On the Pebble App press the “watch icon” in the upper right corner of the screen – you should see your watch there – press (i.e. select) it.

  7. Go to Settings/Bluetooth on the watch

  8. You should now see the watch on the phone – make sure the watch and phone are SIDE BY SIDE

  9. On the Pebble app you should see that it sees the watch and is telling you to press the “upper right button” on the watch. DO THIS – Then the phone should tell you “congratualations” you have successfully paired.

Hope this helps

JR


#5

Yes, tried that previously - still the same issue.

[quote=“Robert29, post:3, topic:31759, full:true”]
I am not sure why you would think the “button is not activated” but this step is required to complete the pairing process.[/quote]

I say the button is not activated because the watch doesn’t change from showing the time to display the top right button when I try to re-pair it (with it previously successfully being paired the day before). When I delete everything and start again it does it but this evening for example she’s come in from a day out having re-paired the watch last night. Tonight I open the Pebble App and it’s got Not Connected and a Connect button showing - see picture. I click Connect and the phone goes through the same process but the watch never presents the Click top right to Pair (as it does when you wipe it completely.).

Thanks for the detailed pairing instructions - but just to summarise - if I start from nothing it successfully pairs and will download the information from the watch but it loses the pairing every single day. The phone says it’s connected in Settings/Bluetooth but the Pebble APP says it’s not.

Her previous pebble watch which was paired to the same phone didn’t lose connectivity every day and my own (to a separate phone) doesn’t either; that’s why I think the watch is faulty.

We shouldn’t be expected to go through the pairing process every single day; realisitically all the other devices that I have that are connected via BT do not have any issues - just this watch.


#6

Hello Again Smudge,

Now I better understand where you are. Technically I would say that you are still “Paired”, but not successfully “Connected”. This is a problem I have experienced on and off ever since I got my first Pebble. To be honest, based on my experience, I think most of the problem lies with the phone/app and not the watch.

I have tried numerous things when I get to where you are… but the one that seems to be most effective and has ALWAYS solved my issue in the past is to simply turn my phone off and then back on again. PS – Make sure that the Pebble App is running after the re-power-up. Next time you have an issue, see if that doesn’t work – PS I think if you are running 11.2.2 and you have set the Pebble App to run in background, it will automatically restart… but check anyway.

JR


#7

PS – I just noticed that you told someone else that you had tried this… but it almost always works for me.

JR


#8

Robert, Yes we’ve tried turning the phone off and starting completely - something we really shouldn’t have to do and we certainly didn’t have to do with her previous pebble.

Yesterday was a good case in point -

As you can see - the phone is connected (as it’s not showing the re-connect option - but the step count nor heartbeat hasn’t been sent to the phone.

Even if we go back a couple of days - it’s not syncing fully - going back to Saturday the watch shows 19,000 steps but the phone after syncing only shows 284. (It seems I’m only allowed one image in a post at a time) - so I’ll add the other image in the next post.

I think I’m in agreement that the App is the issue - it would be good to get some input from Pebble as it’s certainly not working as it should be and my wifes Christmas present is starting to annoy her now due to it’s continual problems and to be honest I’m getting annoyed with it too as I’m the techie in the house so I have to fix it.


#9