Pebble 2 stuck on pebble.com/app screen after reset


#1

Hello all, I hope someone can help. I just received my Pebble 2 in the mail yesterday. I set it up and worked out of the box. I was having issues with it staying connected to Bluetooth so I did a factory reset on the watch. Now no matter what I do it always goes back to the Pebble.com/app screen. I hate to have to return it already, I would just like it to work. Any tips would be greatly appreciated.


#2

After resetting the P2, did you forget the device in the BT settings on your phone?


#3

After much searching on the internet I found a solution that worked:
Unpair Pebble from Bluetooth settings on phone, delete Pebble Time app, restart phone. Meanwhile, hold back, up and mid buttons on Pebble until loading bar displays. When phone reboots reinstall Pebble Time app. Add watch as before and hopefully it should work.

It was the uninstall and reinstalling the app that made the difference.


#4

I have same problem with u… my pebble 2HR stuck on pebble.com/app… i have tried everything and it wont fix… always stuck on pebble.com/app screen…

Did you have another solution ???


#5

I am having the same problem! My friend gave me his pebble smart watch. I can’t seem to get passed the screen that says pebble.com/app with a icon of a clock face. I have tried the above solutions and this hasn’t worked (I can’t unpair as I have never even been able to pair the device).

Thanks for your help!