Pebble 2 will *not* connect to App (Android)


#81

You must try to force using BLE in gadgetbridge


#82

Is gadget bridge for IOS or Android?


#83

Got this from support…

To get out of pairing mode, can you please hold down the bottom right button on your Pebble watch. If held long enough, two blue spinning circles should appear. Once this is complete, uninstall the Pebble app from your mobile phone. Now that you have uninstalled the app, can you please forget the Bluetooth pairings of the Pebble on your mobile phone. Once you have finished this, can you please restart your mobile phone and then install the Pebble Time app https://itunes.apple.com/us/app/pebble-time/id957997620?mt=8?33 After this please attempt to pair as you normally would.

Playing with my watch all weekend found this in internet. Took 20 minutes and it’s as good as new.


#84

Spend whole day with this method - nothing. Paired with Gadjedbridge but GB constantly disconected from pebble and will not connect again before you manualy tap - “conect to device”, also GB cant install software (always error) and Pebble Health useless with GB. GB not alternative for official Pebble App for now :confused:


#85

I just got my P2 and had same problem with you guys, GB isn’t running as well. Im running on a Android v5.1


#86

Hi,

I have exactly the same problem with my brand new Pebble 2 and both ASUS M180 (android 5.x) tablet and a Ulefone Power (Android 6.0) phablet
Luckily I could connect easily with an huawei Honor 5C (android 6.0)

From what I’ve seen the problem is device dependant, not android version dependant.
Except that @Tumi has announced the stuff worked with a Ulefone Power like mine.
@Tumi could you confirm ?
What could be the difference between your Ulefone Power and mine ?

Anyway, I suspect the app to be the problem rather than the firmware as I could not connect to the Ulefone and the Asus whether with the initial firmware installed on the watch or the one (4.3) I finally managed to install with the Honor 5C

Looking at the log (android log, use contact support to send the mail with a TarGZ to yourself) I’ve seen 2 messages which are maybe related to the connection problem

[BluetoothManager] Connecting to [ name = PEBBLE B6B5, address = 4F:34:2E:2E:5C:4F, transport = LE] failed: result = [result = NOT_AVAILABLE, reason = NO_PPOG_CONNECTION_HAS_ENCRYPTION, newAddress = null, failingGattStatus = 0, failingState = PAIRED]

and an increasingly dellayed connection timeout followed by an error about bluetooth LE method unavailable

12-22 10:25:10.089 11820 11820 D Pbl: [ConnectionStateManager/app] actionProcessBackoff init for [ name = PEBBLE B6B5, address = 4F:34:2E:2E:5C:4F, transport = LE] period = 1000 ms

12-22 10:25:10.097 11820 11820 I Pbl: [PebbleBluetoothAdapter] getLeState: error doing reflection
12-22 10:25:10.097 11820 11820 I Pbl: java.lang.NoSuchMethodException: getLeState []

Those errors where also available with the initial firmware so I suspect them to be the problem core… but I’m not sure as as always with java stuff you have to deal with a huge bunch of (mostly pointless) log lines ( and throwing null pointer exception errors is a major programming pattern in Java :wink: )

As everybody here I’ve no news from pebble support and I assume we won’t have any as the developpers will probably be assigned to fitbit stuff. Too bad.

I’m going to investigate on genuine open source solutions to use this nice piece of hardware.
Does anyone has some links related to open source firmware for pebble ?


#87

thanks


#88

Thanks for your suggestion! But it did not solve the problem.
Yesterday I tried to pair with my brother’s IPhone 5S and … and a Christmas miracle happened. The Holy Apple did it. With the official Pebble application. It automatically installs firmware 4.3 and proposes to configure.
But I do not want to buy or use an iPhone. So I forgot the pairing with the iPhone on the watch and try again with an Alcatel Pixi 4 (6) (Android 5.1 - Blutooth 4.1)… and again impossible to connect to the watch. Uninstall the application, reinstall, restart the phone, GadgetBrige, … and no results.
So I did a reset on the watch and … back to the original firmware. Fu … !!!
At least I know the hardware is OK
Is it too hard for Pebble Team to debug the app?


#89

I had tried everything, but couldn’t connect Pebble 2 and Xiomi Redmi note 2. Finally, I paired it with Nexus 6. Watches got an update 4.3. I deleted connection to Nexus from Pebble settings menu and then Xiomi paired without any problem.
So, try to update the watches from another phone, delete connection from the pabble and don’t do a factory reset


#90

I already tried this hint with MEIZU doesn’t work.


#91

Thank you so much. I was agonizing for days over getting my pebble working, and even debated putting a new ROM onto my phone. Turns out the GPS thing was what I needed. I also tried out gadgetbridge, but I failed to notice the note on GPS. Thanks again!


#92

Thanks so much!! I was about to give up, but ti was just about the GPS


#94

I have Android 5.1 and just bought 3 Pebble 2 SE smartwatches. Same problem. Need to solve this one. I need to use this Android version. Any ideas what is causing this problem?


#95

I have been unable to connect to my Pebble 2 after the latest update to the official android app.
It will continuously prompt to turn on bluetooth.
It never did this when i first got it during the summer.
Tried resetting the watch but same issue.Think it’s the app


#96

Same Problem here.
Keep losing connection and wont reconnect.

Have to forget device on both sides and some times it workes some times not.

Huawei P10 on Stock Android 7.0
Pebble 2 HR


#97

OK… I moved from Alcatel to Samsung phone. What you have to do is clear the Pebble data & cache after you download the Pebble app to your phone. Then you have to clear the previous phone setting (Alcatel) from your watch and then enable your new phone (Samsung) onto the watch. It is fairly easy and self-evident. The directions appear on the watch face when you press “BlueTooth” on the watch and then it proceeds to connect accordingly. It sound more difficult than the written description, but once you are in the “BlueTooth” connection, it proceeds accordingly and automatically.


#98

I have the same problema with Huawei Y9 and pebble steel