Pebble app & iOS 11


I’ve always had connection problems with my pebble unfortunately, so I haven’t had much different experience.


Yes. (Sorry for my english :confused: )


NP! Now I don’t have to buy an Apple watch. !!!


With the possibility of the pebble app and servers shutting down, if I get the opportunity to get an Apple watch, I’ll try to take it. I will really miss my pebble. :frowning:


Ever since FitBit bought Pebble and issued the Pebble App update I have had random disconnects and have not seen the LE connection under the BT in settings on my iphone 6s in months. My watch randomly disconnects up to 4 times a day. Then I have to “forget” all the connections and reboot both devices before they will play nice with one another again. Very frustrating.


Voice to text does not work either, I’m have connection issues with low power mode on iOS seems to disconnect randomly


My problem with iOS 11 is that the pebble app occasionally gets killed even though it is granted permissions to operate in the background and I have to restart it to resume connection. My uneducated guess is that it has something to do with app offloading in iOS 11 as i’m using a 16gb version of the 6 plus and it’s low on free space almost all of the time.


I don’t think it’s a space issue, because I’ve got plenty of space on my phone (I have a 128GB iphone with only half of that being used at the moment). But ever since the iOS update, I’ve found my pebble (time round) disconnecting on a rather frequent basis - I’ll only notice when I stop getting notifications, and then I’ll discover when I open the app that I have become completely unconnected and have to go through the entire connection process again.

I’m not sure what’s driving this - but I have also noticed that my phone itself has frozen/rebooted several times since the update, and when this happens, my beatsX headphones also become disconnected - they reconnect automatically when the phone starts up again, but wondering if this may be a phone issue rather than an issue specific to pebble?

I’m going to do a full iOS reinstall this weekend from my computer/itunes - sometimes that solves the “bad iOS upgrade” issue when I’ve upgraded via the phone.


I’ve also had issues with my Pebble Time frequently disconnecting from Bluetooth – it’s gotten to the point where I can only use watchfaces that vibrate when the watch disconnects, that way I can attempt to fix it. Best way to get it to connect again is to kill the app from the multitasking screen, then open it again, but there’s basically no way to fix the overall issue (I’ve factory reset both my watch AND my phone, and neither worked).

What I’m a little more concerned about is the fact that the official Reminders app seems to have disappeared. I mean, one second it was on my watch, the next it was gone from the watch, the app, AND the Pebble app store. Am I the only one having this problem, or Reminders really get axed?


I recently purchased a new Pebble Time and use it paired to my iPhone 6. The unit has worked flawlessly until today, when I updated to iOS 11.0.1. Now I continually receive an error message: Please go to the iOS Bluetooth Settings menu. Turn Bluetooth off and on. Then open the Pebble app and try again.
I have done this several times and have even deleted and re-downloaded the app several times. The app allows me to pair the watch with the iPhone, but on the watch, under Bluetooth ,it states that I am connected but no LE. What can I do to resurrect my watch to its previous state?


Yesterday, my watch re=booted without my doing anything and it is functioning perfectly. Cannot understand what happened, but am happy that I once again have a fully functioning smartwatch


The only bugs I discovered is that the Bluetooth connection is off sometimes and have to be “rapaired”


I’ve got a first generation Pebble that I love, but updating to iOS11 has caused a bit of “hicupping”. Quite frequently my iPad (which I’ve paired to the Pebble) notifies me that the developers of the PebbleGPS app need to update it to iOS11 specs. I’m getting some repeated notifications that return as soon as I dismiss them. It’s a pest. I guess I should get rid of the GPS app within Pebble and find a more recent incarnation of it?


I have solved my IOS 11 Bluetooth disconnect issue. After much flailing, and, actually ordering a Fitbit Blaze because of the continuing instances of my Pebble 2 disconnecting, I found a random post on Reddit which said kill then restart the Pebble App every morning and your disconnect issues will go away. And, that is true! Just double-press the home button and swipe up the pebble app. Wait a min or two, then restart the pebble app. You’re good to go.


Thank you so much. This solution worked for me also. In fact it worked once my pebble disconnected from my iphone and nothing short of a total re-pairing process would work, but this in fact worked! I was on the verge of buying the new Apple Watch.


Glad it worked!


I am now running 11.03, which was supposed to fix known bugs in iOS 11. It was only since this update that I noticed that Voice Text and Voice Text Replies are no longer working on my Pebble 2 HR. Others have noted this problem. I also haven’t received notifications from “Maps” since the upgrade to 11. grrrrrr