Pebble can't open this one specific app anymore?


When I first got my pebble classic a few years back I installed the Kana Teacher app on it ( and it always worked just fine. Some time back pebble had an update on my phone (the actual app I run on my phone changed from an orange pebble icon to a silver icon, but it mainly works the same as the old one). This was the update that allowed the pebble watch to have unlimited number of apps installed as opposed to the old limit of installed apps it used to have.

While it’s great that I can install as many apps as I want, for some reason that app above (kana teacher) just refuses to work. When I select it the screen to just “shakes” slightly to the right as if it’s about to open the app, but then nothing happens. The app just won’t open. It used to work just fine and now suddenly it just won’t work? please help, it was a great app : (


FWIW, it loads and works on my Pebble 2. Maybe its more recent versions exceed the amount of app memory available on the Pebble classic. You can ask the developer Filip (his contact info is on his github page); he may be able to provide you with an older version to side-load.