Pebble stops showing notifications


This started I don’t know when, maybe some months ago.

Pebble suddenly stops showing any notifications, there is no indication of bluetooth disconnecting. I need to open Pebble application Manage Pebble->disconnect->connect to get the pending notifications. After this it’ll work again for a random time. Then it just stops and I need to disconnect+connect again.

I have added Pebble and Android Wear to “Not optimized” list in phone’s battery settings. I think this means they won’t be closed automatically.

I don’t know if it started after Pebble update or Sony update, but it is annoying.

Anyone else having this problem? Any solutions?

My devices are:
Pebble Time V4.0.2
Sony Xperia Z3 Compact with Android 6.0.1 (23.5.A.1.291)


Not sure if it helps but ensure that the pebble mobile app is always running in the background :slight_smile:


Does you phone have a power saving setting that turns off radios when the screen is off? My Galaxy Note 5 has such a setting (Android 6.0.1) and when the phone turns off the Bluetooth radio my Pebble disconnects and the re-connect features times out after a while.

In my phone the setting is found under Battery > Power Saving Mode ? Restrict Background Data.


I tried to keep the pebble mobile app on “recent app” list, but that doesn’t help.

I’ve also tried to set power savings off for pebble and bluetooth where I found any options, but maybe there are other options.
I’m not 100% sure, but I think that the connection stays open while listening music and I have Music Boss installed on phone and pebble. Maybe that keeps the connection open. But I’m not listening music all the time.


Having the same problem with the same phone and a pebble time steel.

I think it only started happening after upgrading to v4.0.0


Pebble Time: v4.0.2
Pebble App: 4.0.0-1209-98b6e71
Phone: Z3C D5803
Android: 6.0.1
Firmware: 23.5.A.1.291
if that helps at all.

4.0 has been very unpleasant for me. I have Pebble and certain other apps that might generate notifications in the ‘not optimized’ battery optimization category. I actually removed and reinstalled the pebble app because it was doing this.

@almightywhacko, pebble still thinks it’s connected, watch still thinks it’s connected. In fact, the pebble app thinks it’s getting updates. The health page said “updated 3 min ago” but my step data was missing for yesterday and today. Apparently, mine has been out for over a day without me realizing it. And yet, my sleep data was there and I received a notification about my sleep this morning.

After disconnecting/reconnecting the pebble via the app I watched the step data update on the screen for both days and received 14 notifications.


This happened on the recent Android update. Try to take off your phone out of POWER SAVING mode. Prior to the update, Pebble would work out fine even on Android’s power saving mode. This time, the new power saving mode cuts off Pebble from the Internet, meaning, it only pulls off new data (weather, stock quotes, bus schedules, etc.) if you actually select the Pebble app on your phone but when you tinker with your watch, app says error or just keeps showing old data. I have tried turning off restrictions on my Pebble app to encourage it to just stay running in the background with Power Saving mode - it doesn’t work well, Android is very restrictive now. Yes, it does run, but after a short time, it will cut off it’s internet access. You can only get major notifications like text, calls, etc. because it’s maintains its connection to the phone but most of the apps don’t pull out new data unless your Android phone is completely off POWER SAVING mode.


I have stamina mode set to “never” and ultra stamina is not active.

In battery optimization (“Select apps that you do not want to apply battery optimization for (apps that are not restricted in the background.)”) I have selected Android Wear and Pebble. Other apps on list are Anonymous Usage Stats and Google Play Services, which cannot be taken out of the list.

What other power savings can be disabled to make Pebble work without sleeping?


What notification system are you using with your Pebble? The default Pebble notification system never sends past notifications to your watch if those notifications appeared on your phone while the watch and phone were disconnected.


Same here since pebble update 4.0

Putting the watch into airplane mode and out doesn’t help, you have to disconnect and connect inside pebble app.

And yes, it sends past notifications as if they were on a “pending” fifo waiting to be sent…

Sony Xperia Z3
Android 6.0.1


@almightywhacko : what @DSommer said. I don’t know if the notifications were for the span of time it was connected but silent but the step data is.

If any Pebble staff are reading this I am getting so fed up with it. The Pebble has been a reliable device for years to the point that I never have my sound on my phone. My wife has tried to get a hold of me and been unable to because my watch has decided to go on the fritz without notifying me. If there’s anything I can do to help end this let me know.


I too observe this behaviour - SMS and WhatsApp messages being received by my phone, but not appearing on my Pebble.

I am also becoming fed up because my phone is also always on silent at work, and I’m missing messages from my wife!

It’s such a shame because the Pebble used to be reliable, but now it’s simply not :disappointed:

Turning the Pebble off then on again fixes the issue, until the next time it (randomly?) happens.

Pebble Time: v4.1
Pebble App: 4.1.1-1255-d634173
Phone: Sony Xperia Z3C D5803
Android: 6.0.1
Firmware: 23.5.A.1.291


Add me to the list of people who’s notifications have completely stopped since my watch updated to 4.1. Using a Pebble Time with a Oneplus 2. A real shame because of how reliable it had been before.


Randomly, and with no input from myself, all my notifications suddenly started working again today!


I have exactly the same problem (also Sony Z3c with latest firmware). So far I haven’t found a solution.
And since it also doesn’t start to work again after the phone is turned on, pebble app is started and test messages are sent from the support section in the pebble app that playing with the power save settings in the phone will help in any way.


Hey guys,

I have the same problem! I am also on Z3 compact with android 6.0.1 and Firmware 23.5.A.291. But I have an “old” pebble classic with Software version 3.12.2.

I upgraded my phone to the newest firmware at 2 Oct, but the pebble update was released on 26 Sept. Problems started after upgrading my phone. So maybe it has something to do with this smartphone version. Maybe it’s because the stamina modus they readded.

@pebble Tell us if you want any logfiles from us! I tried to find something out with catlog but I couldn’t find any interesting ( but I’m also not very familiar with catlog)


Adding the pebble app as “not optimized” app under battery settings, seems to work for me. I didn’t notice a silent disconnect today.


Pebble app was added to the list of non-optimized apps as soon as I was using Android 6 on my Z3c, so at least for me it doesn’t solve the problem.

Just at this very moment I can go into the Pebble app, it shows me my pebble time steel (version 4.1.3) as connected but I receive no notification. I can go into the “support” menu and try to send test notifications, but neither for textmessages nor phone calls or e-mail anything happens on the watch.

I also tried an alternative software for the pebble app (open source gadgetbridge), but this shows the same problem, after some time no more notification. This means it’s most likely some problem between the z3c and the watch itself. Maybe something that needs to be fixed in the firmware of the pebble or maybe it’s simply the fault of the phone.

Not sure if this forum is the right way to report this to the pebble team, so far nobody showed interest in this thread…


Unfortunately, it didn’t help as long as it should :-(. I don’t get any notifications anymore, although I added the app to the list…


I added the Pebble App and the Android Wear App to the list of “non-optimised” apps a couple of days ago.

So far my notifications have continued to work, but due to the “random” nature of this behaviour I think it’s too early to say that this has fixed the problem. I’ll post again in a few days…