Pebble stops showing notifications


I’m probably tempting fate by replying, but I haven’t had any notifications problems since adding Pebble and Android Wear to the list of “non-optimised” apps. Fingers crossed!


Tried adding Pebble, Android Wear and Music Boss to non-optimised and it seemed to last longer before stopping the notifications.

Just about to try 4.2!


Update yesterday to version 4.2, still the same problem. I think it has been mentioned before but while the notification stopped working, it’s no problem at all to controll my music app through the watch, however the screen on the watch does not update and show that music has started/stopped.

Sounds like data is flowing only in one direction, from the watch towards the phone. This might explain, why the pebble app does not recognize that the watch is gone, since the watch can still send its heartbeats towards the phone.
On the other hand it doesn’t make sense since the watch itself does not detect that its no longer properly connected towards the phone.

Frustrating situation, would be so nice if somebody from the Pebble staff would take notice of this thread!


I’ve finally raised a support request - will post any updates here…



Some days ago, I also added Android Wear (additionally to the pebble app) to the none optimized apps. But there was no difference.


I will also write the pebble support.


This reply arrive two days after I sent my request for help, I am now receiving notifications again:) Hope this helps others.

Describe the problem you are experiencing:

I no longer receive notification alerts/vibrations on my watch when texted emailed. I only receive alerts when someone calls me. Please help with this issue.

Hi Richard,

Thank you for reaching out!

This issue can usually be resolved by disconnecting the pairing between your phone and your Pebble by shutting down both devices.

Boot both devices back up, re-pair and you should be reset.

I hope this helps!


I have the same problem with my new pebble (5 days old) and my Sony Z3 running marshmallow. It seems that notifications work fine until I go out of range of the phone bluetooth then when the watch reconnects, I don’t get notifications. Force stopping the app cures it, but of course you have to notice that it needs doing. Annoying to say the least. I am not sure whether it started when I updated the pebble app a couple of days ago.
The reply from pebble re pairing is not helpful for the same reason…first you have to notice that you need to do it.

Update…notifications just stopped without the watch having been disconnected from the phone bluetooth, so it looks like it is just a random issue. I may try rolling back my pebble app to the previous version…



This is the answer after using music boss and don’t care about notification :

(in English: “failed”)

… We need a software solution. Not a “please restart your devices” solution.

WTF @pebble are you SERIOUS?!!?!?!?!
You have reached the reply limit for this topic

We’re sorry, but new users are temporarily limited to 3 replies in the same topic.

Instead of adding another reply, please consider editing your previous replies, or visiting other topics."

Anyway. This ist the reply from pebble:

"Thank you for letting us know–I’m happy to help!

This issue can often be solved by toggling Airplane mode on, then off on your phone. If this doesn’t help, please use the steps below to correct the issue.

  1. On your phone, open Bluetooth settings and find any devices labeled ‘Pebble’. Tap the gear icon, and forget the devices.
  2. If possible, open your watch’s Settings, and open Bluetooth, then select and forget your phone. If the menu’s unavailable, simply hold the down button for 10 seconds.
  3. On the watch, press and hold the left button and right middle button simultaneously until “pebble” appears.
  4. Re-open the Pebble app and follow the instructions to re-connect your watch.

Instructions for setting up your Android notifications can be found here:

Let us know if the issue persists after completing these steps, and we’ll continue to troubleshoot with you.
Mindi Ann"

I will try this later.

I can not get any notifications on my pebble time

Tried restarting my phone…notifications stopped after a few hours
Tried to roll back the pebble app to the previous version but it appears not to be possible :unamused:
Waiting to hear from Pebble Support.


I restarted the watch which solved the problem… for about 26 hours…just noticed that notifications have stopped again sigh. Nothing from pebble but looks like the update to the pebble app last week caused lots of people problems.

Update…after force closing the app yesterday I got about 22 hours of notifications working. Seems to last less time after each force close of the app.


Got a response from Pebble support saying that toggling flight mode on and off can restore notifications. OK, so that IS quicker than force closing the app, but it still requires one to notice that notifications have stopped and so means you can’t rely on the watch if you have your phone on silent. Misses the point rather.



The solution I posted didn’t help me, too. So I replied pebble that this only helps for a couple hours. They forwarded my request to the technical support. I will keep you up to date here!

PS: After writing to the site administration I am now allowed to write more than three posts in one thread. Yeah!


I got answer from pebble! They are working on a fix!


Thanks for your email!
Unfortunately, we’ve confirmed similar reports of this issue recurring from other users with Sony smartphones, and are investigating a workaround to try and address it.

Some users have reported that resetting the Bluetooth software cache can often help get it reconnected for some time. To do this, please open the settings app on your phone, then select App Manager. On the page that appears, scroll sideways to the “All” tab.

On the All tab, tap on Bluetooth Share, then tap on the Clear Data button. This will reload the Bluetooth module and can help address some connection issues.

In addition, allowing the Pebble app to run in the background on your phone will also noticeably improve the reliability of the connection.
Best regards, "


It’s good news that they are working on it.

I’m suffering from the problem again. I think (but am not sure) that leaving the phone completely motionless on a table causes notifications to fail to be sent to the Pebble. But keeping the phone in your pocket (moving slightly) allows notifications through? I’ll try to do some more testing…


Disregard my last comment - I’ve just had a couple of notification failures while my phone was in my pocket :frowning:


I hadn’t realised that it was just Sony smartphones that were the problem (I do have a Sony). I will try the resetting the Bluetooth cache.
I have noticed that sometimes, when I think notifications have stopped, they do appear but very delayed. Hopefully the fix they are working on will do the trick!


It’s not just Sony phones, I have a One Plus X and it is happening to me too…


Had a similar reply from support about clearing the bluetooth cache on my z3 compact:

  1. From settings, go to apps
  2. Tap the three dots in the upper right hand corner.
  3. Tap “Show System”
  4. Tap “Bluetooth Share”
  5. Tap “Storage”
  6. Tap “Clear Data.”

Notifications have been working since doing that a day ago, but I’ll not say it’s resolved just yet!


I’ve tried that a couple of times over the past couple of days, but notifications have been really unreliable for me even so.


I have the same issue as many of you. Latest software, latest Android (Sony Xperia Z3 Compact). To resolve it, temporary:

  1. Open Pebble app
  2. Disconnect Pebble
  3. Connect Pebble

Once I connect it again, I receive old messages that have accumulated and have not been delivered to my Pebble. Then it works as normal until I notice the issue maybe hours later.