Pebble stops showing notifications


Sometimes this works for me, sometimes it makes no difference. Now that my Pebble is reliable only for telling the time, I’ve had to turn my phone notifications back on to sound / vibrate, and am using it the “pre-smartwatch” way.


Same problem here, Hopefully this problem will be soon resolved, as the notifications have become extremely unreliable.


I’ve just had to reboot my phone (Sony Z3 Compact) to get my Pebble Time to connect after being out of bluetooth range overnight. Nothing else mentioned in this thread would work :frowning:


Just wanted to chime in that I’ve got this exact problem too. Pebble Time and Xperia Z3 Compact. My usual temporary fix is disabling then reenabling Bluetooth but I hope someone at Pebble is aware of this thread if the problem seems so common with these phones .


Hello , today I just got the pebble 2.

Notifications for whatsapp en gmail are working.

But they don’t work for messenger and fb messenger.

I have a oneplus x.

Tried everything above, no luck.


I was testing with notifications to myself. That is not working but receiving sms from other people works without a problem.


Got an email from pebble support saying they think it will be fixed with the next release of the pebble app.

Crossing my fingers…



This bug is getting very annoying. -.-


My Pebble is more or less useless with this problem…


Not sure if this is coincidental, but I removed a watch face that was listed in the background app section that I wasn’t using and I haven’t had a hang (that I’ve noticed) for best part of 3 days


I tried that earlier today and it seemed to help. Now, Maybe ten hours later or so, it has stopped working again. Thanks Obama.


The watch face also seems to stop battery+ from working correctly.

Only a guess, but maybe also related to badly written apps/watch faces


@Sjh85 Thanks for the tip about turning the phone’s Bluetooth off and on again. For some reason I didn’t think of doing that.

I’m now using Tasker to automatically toggle Bluetooth whenever I receive a WhatsApp or Messenger message. So far, so good - I’m beginning to think this workaround may have made my Pebble dependable again.


Well, I spoke too soon (again!). Today, toggling Bluetooth off and on does not result in my WhatsApp notifications coming through to my Pebble. So it’s back to using my Pebble as a dumbwatch and using my phone for messages, so that I don’t miss any.



That’s a shame. I did have a go at toggling it using Tasker too (I tried having it toggle every hour as long as it wasn’t connected to any other Bluetooth device) but yeah it doesn’t seem as easy as that. Pity.


Hello, same problem as you with latest update of Xperia Z3. It seems to be related to Marshmallow.

An other topic talking about it:

By my side, I tried a lot of things, including factory reset of the phone… without luck.

So, I rollbacked to lollipop on my phone, and the problem disappeared. I won’t update to marshmallow again until the problem is not solved.

I hope that pebble will found a workaround… I’m afraid that sony won’t fix this mess, since they said that Xperia Z3 won’t receive Android N update.


So tired of this…


My Pebble is completely worthless and it only lasts 2 days. It’s not just marshmallow. It’s pebble 4.0. I think I’m going to try loading the latest Sony concept build to see if it makes a difference. Prior to 4.0 I have recommended the Pebble without hesitation. Let’s just say that I’m not doing that anymore. I’m also seriously considering cancelling my time 2 preorder. Pebble has had 6 weeks to fix this and it seems worse now than when I posted then. I rarely receive notifications anymore. The only reason it’s still on my wrist is that it feels funny when it’s missing


Try to disable notifications from apps that are sony-firmware-specific, like lounge, what’s new etc. (do it under notifications tab in pebble app). I noticed that these applications are visible there as if they have already sent something, but I don’t really remember any of them actually seen on my watch.
MAYBE they get stuck somewhere in between blocking everything else…? (just a theory)

After disabling them and conducting the bluetooth reset (everything with cache and so on), I feel a big difference. I’ve done it on Saturday and everything is working fine since then. Fingers crossed :wink:


It’s not Marshmallow. Its the last update for Marshmallow from Sony (23.5.A.1.291). Just install an older Version like 23.5.A.0.575 for your Smartphone and you should be fine.