Pebble stops showing notifications


I have an Asus Zenfone 3 and the same problem. Everything worked perfect with my Samsung Galaxy S3 Neo, changed to a Asus Zenfone 3, and everything was all right, but after a OTA actualization, my pebble only shows notifications of phone calls and appointments, no whatsapp, no telegram, no e-mail.

I added the pebble app to “not optimised” in battery settings, and disconnected and connected my pebble from the app on the phone, and that solved the problem for a couple of weeks, but, another OTA actualization brought back the problem, and now there’s no way to make it work properly.

I’m really frustrated!


I ended up installing Notification Center for Pebble (as suggested above)
It totally replaces the built-in notification system (you actually have to disable the built in one to not get every notification twice); which is unfortunate if you don’t want to mess with NC’s relative complexity. but it solves the issue. The notifications keep coming in and don’t stop


I’ve given in and am trying this new notification centre as my theory about watchfaces proved incorrect: I had notifications stop several times yesterday even after restarting everything. Fingers crossed.


Installing Notification Center sorted it for me. Not quite as slick as the built-in system but it’s a lot better than missing notifications! Thank you.


hm… has sony done something? for the last few days I see a lot of notifcations working, as before?


Don’t tease me. Notification Center is absolutely destroying my battery life so I’m going to uninstall today and hope you’re right!


Aaand mine stopped again after working fine for three days.


Yup, same. Just dropped out twice within one hour. And guess whose Sony just went out of warranty yesterday!


Notification center also seems to stop occasionally but on the whole I get notifications more reliably. However, downside is that it doesn’t send phone calls so if the pebble app has stopped sending notifications I don’t get an alert. Anyone got a better solution yet?


So. Tired. Of. This. Shit.


Amazingly, Sony accepted my phone for repair under warranty for this issue and sent it back, no charge. This time it did five whole days before dropping connection!

I’m sending it back again with this printed out in the package.



What an honor :slight_smile:.

You must report us what the say!

Luckily I don’t longer own a z3 compact. Since Sony drove their smartphone business against the wall, I now own a oneplus 3t.

And yeah… I don’t have any connection issues with my pebble anymore ;-).


Hey, is it possible to do the rollback without rooting the phone? I’d much rather fix it myself but don’t fancy bricking something that’s within warranty.



You cant brick your smartphone without unlocking the bootloader. And without unlocking you bootloader, you cant lose warranty. And you only have to unlock your bootloader, if you want to install a custom rom, like Cyanogenmod (LineageOS). But yeah… due sonys “good” community politics, there are nearly no custom roms for this device.
If you want to install an official rom, also if its modified, you dont have to unlock the bootloader.

Unfortunately, I dont know any “official” method to install an older version of this OS. I only know the way with the flashtool:

This program has a section, where you can download ALL roms from ALL sony devices and afterwards flash it.

Here is a good tutorial: You can use this tutorial 1:1 for your device and the needed Marshmallow version. Just look for your device and download the needed version.

Make a backup of your files from your internal sd card and your smartphone apps. Apps will be deleted and if you hit the “wrong” button, you could also accidently format your internal sd card.

If you have any questions, feel free to ask!


cba :stuck_out_tongue:


Thank you for the advice. Sadly, Flashtool just hangs when trying to bundle the FTF file.

The version from your link didn’t have the “unpack automatically” option so I followed instructions here but after I click “Create” in the Bundler it just hangs.

I think I’ll just send it in as planned.


Well thats right. Before I resend my z3 Compact to amazon, I flashed the original software without a tutorial and didnt care about this :D.

I would recommend to ignore this step and continue. If you can choose the firmware later in the dialog, everything is fine. But dont use the guide from 2014. Choose my posted tutorial. This are the same steps I did some days ago.

EDIT: I just saw, there is no old version anymore for this phone. Mh… this roms comes directly from the official sony server. They deleted them -.-.

EDIT2: Here is another source:

There is also a short instruction how to flash this firmware.


Actually it does list the older version you mentioned ( 23.5.A.0.575 ) under “Ireland/O2”. When I download it, though, I don’t get any of the “FILE…” files that are mentioned in the tutorials. Maybe that’s why the FTF generation hangs.

I found an FTF file buried in the new link though so thanks for that. Phone seems to be behaving again - no connection drop in two days now - but if it starts dropping again I’ll install 575.

Thanks for all your help and advice!


Dear God. I successfully downgraded to 575 and used ADB to kill the persistent notification whinging about updating.

Now I can’t install or update anything in Play Store. Everything just sticks at “Downloading…” indefinitely. Multiple restarts, cache clearing etc have had minimal effect. 0/10 would not recommend downgrading! I know I’m wasting my time but I think I’m going to send it back to Sony once again just to see if anything happens.


I’m not sure but it could be Google play store is trying to update themselve. Until this is done, the downloads won’t start.

But because of something the play store can’t be updated… Try to manually install a new version via apkmirror:

It’s just an idea…

And just to be sure: Your system was completely new? There were no apps from your previous android version left?