Pebble Time Steel battery only lasts 1 day


#21

With me it started as about 1 month ago…Only 8h of battery life, even without bluetooth. Factory Reset, deleting bluetooth connection,… Still hoping for some support, but i think that’s just idle hope.


#22

Same thing happened to me. About a day or 2 after their big announcement, battery life went from days to hours. I tried to do an RMA but the door had closed on me. SMH!!!


#23

Let me know if you found any kind of help or resolve…


#24

Just curious. Does every one who experience this issue is with Pebble Time Steel?


#25

Maybe this?


#26

impossible


#27

Well now, sure. But still possible when I gave the suggestion back in May.


#28

Well, it isn’t a hardware isssue, so i don’t see the need to get me a new battery somewhere…@obashy: nothing heard from support anymore and still facing same issue


#29

No support anymore


#30

Hi all. Bought my Pebble Time Steel beginning of August and up until a few weeks back would get 8-10 days from each charge. Suddenly this has plummeted to 4-5 days. Tried factory reset but no improvement. Would love to know if anyone finds a solution. In the meantime seeing if I can return it via Flubit for a refund.


#31

Anyone know of a solution to this other than replacing the battery (I’m not that savvy)?


#32

Given that its a faulty battery, what other solution would there be? you could try singing to it? maybe try a vulcan mind meld?

Other than that you’ll have to replace the battery. its not that difficult :slight_smile:


#33

No one likes a smart ass. In a number of other threads, it was suggested to be a known software bug.

I now have a $300 paper weight, which lasted only 12 months. There’s no harm in asking if anyone has found a solution, other than replacing the battery.


#34

Jokes aside, id still definetly try the vulcan mind meld


#35

I’ve done another complete overnight charge, factory reset and re-installation of the Pebble app. This time I have further created another Pebble account that ONLY has the default watchfaces and have disabled Health. Interestingly the Battery+ monitor estimates a whopping 10 days and 23 hours on a full charge now!

Having had this set up for 3 hours now with minimal power loss (still 100%, rather than the 10% per hour previously), I have turned Pebble Health back on.

So whilst this is by no means a conclusive test, I am thinking this is a software issue resulting from a rogue installed watch face.

So I will observe how Pebble Health is working for the next few days and if the battery remains stable, I will add new watch faces one by one.

Edit: Pebble Health has dropped the estimate down to 8 days, 10 hours… Still good in my books. As long as it can last 5 days I’ll be happy.


#36

Could you please tell, what firmware are you using? Reinstalling 4.3 with removal of all apps and watchfaces didn’t do trick for me…


#37

Sorry, it was a false alarm… The battery app default thinks 100% = the full 10 days. The battery still only lasts 1-2 days max… After a recharge, the app re-calibrates the battery life estimate more accurately.


#38

Hi folks!

I have the PTS since xmas. I was absolutely in love with it.
But suddenly, just 20 days after the first use, and after yesterday’s full charge, the battery starts draining dramatically. 50% -> 7h … :S

Hope this can be solved.


#39

I’ve just realise my iPhone 5 is losing the bluetooth connection with the watch very often, don’t really know if it is phone or watch… could this be the reason of this battery issue??


#40

I have P2SE and it was working fine until last sunday… battery life went from +7days to max 10h, have done all the factory resets etc. Seems that I need to try it again with creating a new account…