Pebble Time Steel finally quit


Well I haven’t worn my PTS for a few days. Went to put it on this morning and it wouldn’t connect. Bluetooth menu said it was but the watchface I was using indicated otherwise. Tried repairing it but wouldn’t take. Reset watch and deleted and reinstalled app. Won’t pair, guess it’s back to mechanical watches for a while.


Do you have another handset or tablet laying around you can test it with?


Have you tried going into the Settings -> Bluetooth menu on the watch while attempting to pair? I went through a period where my Pebble Time Steel was losing connection & refusing to pair quite often, but it worked if I was on that screen. But I probably also had to try rebooting the phone & sometimes forgetting the pairing on the Pebble.

Ultimately, the bug was that my Nexus 5 phone was dying hard (failing battery & spontaneously rebooting). I’ve since bought a Galaxy S8 and it’s staying paired and much more stable.


I did test with my iPad Mini 2 on iOS 10 and it worked. The phone issue I thought was then iOS 11. Called Apple Support and had me reset network setting and was good then. However I still have a warning on the watch faces screen saying that BTLE isn’t working. The iOS settings page under BT says it’s connected. Now I get notifications but no vibration when they come in.


Whenever my iPhone battery dies, it kills the Pebble connection in a way that the Pebble unloads all watchfaces. The workable solution I have found is:

  1. On Pebble, forget the iPhone
  2. On the iPhone (for BOTH Bluetooth connections)
  3. Shut down Pebble
  4. Reboot iPhone
  5. Restart Pebble
  6. Use the Pebble App to re-pair

These steps have worked every time for me.