Pebble Time stuck in recovery mode, app won't go past "Reset Your Pebble" screen


#1

I got a new Pebble Time a few days ago and it had been working flawlessly so far. I had it paired with an iPhone 6 running 8.1.3. This morning I noticed that an incoming phone call wasn’t showing up on the watch. So I went into the app and it checked for updates, then said I needed to use recovery mode to fix it. So I held the top 3 buttons down until it rebooted. (That was probably my first mistake, doing what the app told me.)

The watch is now in the red and white striped recovery screen. When I tap the I See the Screen Above button in the app, nothing happens. I’ve force quit the app, relaunched, gone through the same dance, and nothing happens when I tap that button. I’ve also removed the Bluetooth pairings and re-paired, multiple times, but I can never get past that recovery screen.

Is there anything else I can try? Is my watch bricked?


#2

There was a suggestion in this comment, /discussion/23726/repeat-alerts-and-recovery-mode, to remove all of the notifications from the notification center and then restart the phone. I did both, and also restarted the watch yet again.

During the last stages of the phone restarting, the watch tried to pair with it, which didn’t work. After a few tries within Bluetooth settings, I did get it to pair. Then when I launched the PT app, it started doing a firmware update. When that finished, the watch restarted and finally worked again. It’s now running 3.0.

I’m not sure if it was restarting the phone or clearing the notifications, or both, that got things working, but they’re worth a try.


#3

I have only just received my watch. I was told to press the Up Button - nothing happened. I then pressed and held the middle button and now have a picture of a watch with a lightening bolt. Nothing seems to move me from this position. Can someone help?


#4

I think you need to press and hold the up, middle and left button on the Pebble Time for about a minute.


#5

I’m having the same problem. Stuck with a picture of a watch and a lighting bolt! Grrrrr


#6

JohnDunning01- had the very same problem.I ended up turning the iPhone off then back on while the Pebble and it’s app were stuck. Now everything is fine. Good luck!


#7

This worked for me this morning (Pebble Time). Since this forum has a problem with recent sign ups posting links to solutions to problems (really? Its a link to your own help page…), you’ll have to put in the colon and dots yourself
http(colon)//help(dot)getpebble(dot)com/customer/en/portal/articles/2002603-sos-screen?b_id=8309


#8

Looked at this forum to resolve my issue on iPhone 4s, original Pebble. Found answer here www.help.getpebble.com/customer/portal/articles/2399943-ios-9-3-pairing-difficulty?b_id=8309