Pebble Watch stuck in demo?


I recently purchased a Pebble watch from craigslist. After I got a charger and got the watch turned on it would only display demo information. I tried all of the reset options I could find online, but it was to no avail. When I go into the settings and try to change anything it says that “these settings can be changed on a personal Pebble”. Did I buy a broken watch?

No bluetooth coming from Pebble

As far as I am aware, Pebble doesn’t have a demo mode. Are you sure it’s a Pebble? Can you post some photos or a video?



Never seen anything like that


Weird. Have you tried a factory reset?


It won’t let me factory reset, when I click it gives me that message.


Apparently this is just a demo model used in-store only. It can’t be used for anything. Unfortunately it looks like you were scammed on Craigslist.


Damn, well I knew I was taking a gamble but thanks for your help!


Maybe try installing a custom firmware from - doesn’t hurt to try!


Can you get to recovery? If you can, you should be able to flash any other firmware on it.


@Trav Did you ever sort this issue? thinking of buying an ex display from a store


Ok so… I bought the ex display unit (its in the post), Will update if i get it working!


Yea I did get it working! I’m actually wearing it right now. Shoot me a private message if you need any help getting it figured out


Yay! Just to confirm I got my one working, It went into recovery mode fine when i stopped being an idiot (I was pressing Up middle and DOWN instead of Up middle and BACK as the wording was a bit confusing…) Updated firmware, did a factory reset, works like a charm.

Thanks @Trav


Hi guys.
I recently got a Store Demo Pebble watch which only displays demo information. I have tried all of the reset options I could find online, but it will not exit the demo mode. I noticed you were able to get it out of Demo mode. Could you please guide me through process? I’m like stuck and I’d really like to get it going. Thanks



I have a demo mode on my watch and can’t get it to go to the proper recovery mode. In demo mode it doesn’t allow to pair to a phone so can’t get anything done currently. When I do the up, select and back combo for 30 seconds, it just seems to power off until I press a button then it reboots.

Is anyone able to help?!


as above have one stuck in demo mode can it be done???


I have one in demo mode as well!! i dont know how to fix it. if i cant my watch would have been a waste of money. i dont understand how to do the fix that is above!


can you help me through the process?? my watch is in demo mode as well.


Hi matey please can you help I’ve got a pebble steel stuck in demo and haven’t a clue thank you