Pebble with the Android 8.0/8.1 ("Oreo")


#1

Hello there.

As more and more Android smartphones are getting “Oreo” (Android 8.0/8.1), I would like to ask how good or bad the PEBBLE works with it.

Can we summarize it here, please?

  1. Which Pebble Watch?
  2. Which Smartphone with Oreo (Android 8)?
  3. Whether it worked correctly with the earlier version of Android (if Android was upgraded on that phone)?
  4. How it now works with Oreo (Pebble App and/or Gadgetbridge)?

Thank you!


#2
  1. Pebble 2 HR

  2. bq Aquaris X (Android 8.1 since few weeks)

  3. there was everything fine with Android 7 and the Pebble App.

  4. Android 8.1:
    Android App: pairing+connect is possible only once after the clean fresh Pebble App installation. After the loss of that initial connection, no chance of reconnect. Even not after restart of the phone or Pebble.
    Gadgetbridge: initial pairing is OK, after that only (re)connects manually and shows the pairing dialog every single time. Everything’s fine while connected.
    The phone does not recognize Pebble as trustful device anymore, so Smart Lock (the phone is unlocked while connected to the Pebble) does not work.

I am wondering if I am the only one with such problems after the upgrade to Oreo…


#3

I have pebble 2 from its beginning (preorder it) and it still works perfect with my note 8 (Oreo).
Everything works, no problems at all!!!


#4

I have a Nexus 5X, and have been on the developers program for Oreo from get go.
Initially, there were some problems with pairing and with some of the apps that didn’t fire properly. Also battery consumption was terrible.
Note that this is stock Android (it’s a nexus :slight_smile: )
I loaded the (then) new Android app which was published to the beta channel, by opting-in and downloading from the Play Store. https://t.co/c67MVhCjNQ. Subsequently, I loaded the latest Pebble iterations as they became available, and so my system is fully up to date both on the “O” and the Pebble sides.

The beta version was explored on this thread ~ Pebble App and the Android "O" (8.0)

By the time the final pre-release version of Oreo came out all the issues were resolved, and it now works perfectly for me, and battery life returned to normal.

All the apps I loaded still work, as do the watchfaces.
rgds,


#5

@Ilinkcs: thank you but that beta is very old one (2016), version 4.1.1. The final 4.1.1 which is same or even newer than this beta was published in August 2017.
The bq smartphones have the stock Android, too. Unfortunately, their Pebble connectivity seems to be broken :frowning: … I have reportet that bug to the bq developers but not sure if they will be willing and able to fix.
Still, good to know that this is not a general Oreo problem.

@all: any more experiences with the Oreo (Android 8) and Pebble, please??..


#6

yes, I should have noted that I’ve since upgraded to the most recent Pebble App. Will amend my initial post accordingly


#7
  1. Pebble 2 HR
  2. HTC U11 (Android 8.0)
  3. Everything works fine in old phone (HTCOne M9+ with Android 7.0) and now
  4. When upgraded to Android 8.0, Pebble 2 can’t get connect with phone. I clear its pair record on phone and pair it again, after that it works fine just like old day.

#8

@infodreamtimeshopcom Exact same thing here… installing the app make pebble 2 connect but after lost the connecting, wont connect anymore…


#9

I have pebble 2 hr and after 8.0 it disconnected and would not reconnect, after deleting app and factory resetting watch then reinstalling app it failed to update watch several times but eventually worked. It now works as expected except randomly disconnects, but a manual reconnect does work. It did once disconnect again without manual reconnect but deleting app etc worked again eventually. Takes at least 3 goes to update watch then works as expected. Hope this helps a few as I’d be lost without my pebble.


#10

Pebble 2
Oneplus 5
Android 8.1

Works just fine


#11

Pebble Time
LG G5, , marshmallow
Samsung S8, 8.0
Everything seems to work fine


#12

Pixel2, latest and greatest Android 8.1. everything works on my ptr.


#13

I have a note 8 that was just upgraded to Oreo, works fine with my Pebble Time steel…


#14

The same here, note 8 perfect working with pebble 2 in GTA, Ontario, canada


#15

hello,
i would sugget you the Fitbit Blaze
ive been using it for 3 months i love it
and smartphone i am using is s9
it worked perfectly before and it works perfectly now too
i used this watch with my s6 too and i got no issues with it !
regards
jayesh
Plex Kodi


#16

Please note that we’re talking about “Pebble with the Android 8.0/8.1”, so please on off-topic.