SOLVED (sort of ): Can't Connect after Pebble Time factory reset & App uninstall/reinstall


UPDATE: rebooting the phone seems to have been the missing ingredient. The connection seems to be working for the time being.

I have a Pebble Time which was working great until yesterday. My phone stopped connecting to the watch. I tried factory resetting the watch, and now I’m stuck. When use the Pebble App to pair, I get the pairing prompt on the watch, hit okay on the watch, and then … a minute later I get the pairing prompt again. Sometimes the pairing will succeed. But the Pebble App stays “Connecting”.

Potentially useful details:

  • My phone is a GSM Moto X Pure.
  • I use Bluetooth for other devices – my Garmin running watch, a speaker, Tile – and it works fine.

Any ideas how to get out of this mess? Other than “buy a Samsung Gear S3” :stuck_out_tongue:


Thanks. Will try now!


It worked. And I got one watchface. And now it doesn’t work again.

I will try another cache partition clean. This is ridiculous. They’re doing something, but I don’t know what. They should communicate with us a little. Just a little!!!