Steps won't reset each night


Anyone else having problems with the step counter on their Pebble not resetting each day? When it hits midnight, my steps briefly reset to zero, but sometime between 12:00am and 12:30am, it bounces back to approximately yesterday’s step count total. I’m definitely not walking 12000 steps in half an hour! :slight_smile: The step count on the phone app is always correct though.

The problem has only started since I switched from a Nexus 5 to a Galaxy S8. It’s similar to a bug previously described in 2016, but I’m on the v4.3 firmware of my Pebble Time Steel, not v3.14:

Also, I’m in GMT +8 timezone, and the previous bug (below) applied to positive GMT timezones, but I’m on Android, not iOS, and running the latest Pebble app:

Any ideas? Anyone else affected, especially in Australia and/or GMT +8?


I might have narrowed this down to a bug in the Pebble app on Android not updating to the new day at midnight. Is anyone else with a Galaxy S8 having this problem?

At 12:25am, if I launch Pebble Health and look at the data for “Today”, it still shows yesterday’s data, and the time/step marker is stuck at Midnight (ie the end of the day). If I quit the Pebble app and restart it, same behaviour. If I try to page back a day, it shows me the data for two days ago instead. The only way to get the app to switch to the new day is to reboot the phone.

I checked the time settings on my Galaxy S8 phone and it’s correct, both automatically and manually set. I’m experiencing the same behaviour in GMT +11, so it’s not just in GMT +8. I’m running Android App version 4.4.1-1404-01abd2f76-endframe.


Just I thing I have noticed with Naugat running on my S7 is that it loves to shut everything down running in the background so a couple of things to try is go to the battery settings in device maintenance and make sure to add the Pebble app to the unmonitored list if you haven’t already plus if you haven’t already install the android wear app and just leave it there don’t have to do anything with it because apparently it helps with the pebble communication with the phone and 1 other thing is deep down in the data management can’t remember exactly where it is in the settings find the pebble app in the list and turn it on as it is off by default oh and 1 last thing add the watch to the smart lock if you haven’t already and all these things can add up to the app and watch working as it should as it did for mine.


Thanks for the tips! Unfortunately I already had Android Wear installed and already added both Pebble and Android Wear to my “Unmonitored Apps” list under Battery Settings, so that doesn’t seem to be it. I’ve got Settings -> Connections -> Data Saver turned off in the S8 settings, but I’ve now added Pebble and Android Wear to that unrestricted data list too, just in case. I’ll try adding the watch to my Smart Lock recognized devices now too.

It’s strange, the same version of the Pebble App worked fine on my Nexus 5, and it sounds like it works fine with your S7, so I wonder what I’m doing wrong on my S8!


Seems to be working now! For the last three days, my Time Steel is now correctly reporting steps after midnight again. Looks like rebooting my phone or adding the Pebble to the S8’s Smart Lock fixed it.