Stuck at Recovery Mode


#61

Pedrolane, your advice worked and is awesome and should be moved to top of pebble support. Thanks for saving me heartache.

@pedrolane said:
Every time, I enter Recovery mode, the watch is stuck at screen “Install and run pebble app” and the phone tries to send the last firmware. It never works…

My solution that works every time :

  • Uninstall the phone app

  • Forget bluetooth pairing

  • reboot the watch (press left and middle button for 10 seconds)

  • Reinstall the pebble app on the phone

  • enter your login, pair the watch, update the firmware… and it works

I hope it will help you


#62

Try going into recovery mode again(up, select, and power button hold) then forget your pebble in bluetooth pairing on your device. Reconnect, and you will get out of recovery.


#63

I had the same problem with my Steel. Still waiting for reply from support. Tried everything and still dead. Managed to get 42% but failed midway. Already tried with 5 different devices from iPhone 5S, iPad mini 2, Nexus 6, Galaxy S6 and even the old Galaxy Nexus. Unable to restore. The watch is obviously defective since Day 1.

If Pebble unable to listen / entertain to customer request, please close the company down and sell it away. Will end up like Blackberry. Half dead! May even offload all my Pebbles for the new Gear S2 instead. At least, Samsung has proper support.


#64

I finally got out of recovery mode of my Pebble Original.

  1. Place the watch on the charger.
  2. Press and hold the right bottom button for 10 seconds (this will do a factory reset while you are in recovery mode)
  3. Clear the bluetooth pairing from the phone.
  4. Try reconnecting the watch from the Bluetooth settings menu on your phone.
  5. Finally launch the watch app and continue updating your watch.

I can’t reconnect to the watch in step 5, even it’s paired with the phone already. But I closed the watch app completely (open task list, swipe it away) and reopen, try reconnect again and it works. Then there is one more update and when the update is completed, the PO finally got out of the recovery loop. I think step 2 is the key (which I didn’t try this previously)


#65

I had the same problem with my pebble time.
i was trying to update while connected to home wifi it didn’t work i don’t know why.
i disconnected from wifi and updated from mobile data and it worked for me


#66

For iOS device , if your iPhone is stuck at recovery mode , not worry , there are a tutorial that can help you fix this problem ,https://www.tunesbro.com/iphone-stuck-in-recovery-mode.html


#67

If the problem has not been solved ,you can check the Mobiledic- iOS Data Recovery out on Google ,
You will find a tutorial to fix iPhone Stuck in Recovery Mode
https://www.mobiledic.com/ios-topics/fix-iphone-stuck-in-recovery-mode.html


#68

Have been trying all day to fix my issue of stuck in recovery mode… the watch is less thatn 30 days old and pretty much useless now. Any help would be appreciated
G


#69

Oct 19 2017 When iOS 11 first came out my pebble watch would not connect to my apple 6S, on updates to the iOS 11 a connection was made but only lasted for a short time. I am now on update 03 and the connection is quite solid, however it only last for a day or so. I can’t reconnect via the pebble app although it says it is trying. I have found that rebooting the apple phone, holding the power and home buttons down until the apple symbol appears and allowing the phone to reboot the Bluetooth connection reappeared by itself. The trouble is not with the app or the watch but is an internal Bluetooth connection in the 6S iOS apple phone and rebooting the phone seems to fix this


#70

Thanks ,My apple is back to normal. thanks for your tool


#71

Same problem here! The Pebble 2 is stuck with the writing “pebble.com/app” and then the name of the pebble , but it´s not possible to pair it. My iPhone is not “seeing” it . I already deleted all previous pebble bluetooth connections. Any hint?

Thank you


#72

What finally did it for me was restarting my phone (Android 5.1). I guess that was the one version of “turning it off and back on again” I’d forgotten to try :stuck_out_tongue: . After that and restarting the Pebble app, the watch immediately asked me to confirm the pairing - hip hip, hooray! My condolences if you’re currently still trapped in this loop! :slightly_frowning_face:


#73

here are effective methods to fix iPhone that stuck at recovery mode, resetting, FoneCope tool, dfu mode etc.
https://www.fonecope.com/iphone-stuck-in-recovery-mode.html


#74

I have the same issue before, I was told to need put the phone into the recovery mode. here is I learn from, https://goo.gl/ZP92rd


#75

See solution here: