This is totally instable!


I just got that watch & started trying. Was difficult to connect but finnally worked. Tried it, was nice… Appart it disconnected from BT more than often. So i did factory reset. From that point, it became unbearable :

Phone’s able to see the watch (in BT settings) however the app either don’t, either won’t make the link (nothing appear on watch) either watch request pairing, but then show i should accept prompt on phone, which never appear… What do i do?


Not telling us which platform you’re on, is indeed a good start! This way we can start wild guessing, typing hundreds of lines of text and still not do anything good…


Alright Einstein, sorry for making you loose time with these “hundreds of lines”…! :smiley: I have tested this on 3 phones & they’re all on marshmallow. I kept rebooting all phones, the watch, factory resetting it…

Going in BT settings, sometimes the watch appear, yet it doesn’t on the app. Even though it does, i can’t connect to it. So, does it means BT’s dead on the watch or…? I’m about to order another, while returning this.


My Pebble Time Steel works fine for me with a Nexus 5 running on Marshmallow. Rarely disconnects unless I’m at the other end of the house or out in the garden, and even then it usually reconnects as soon as I walk back within range.

If you’ve tried it on three phones then it does seem like it’s probably an issue with the watch. But you’d probably need to provide more details to diagnose further (eg which model of Pebble you have, which model the 3 phones are, etc).