Urgent! I can't change my language anymore after setting my pebble back to factory mode


Dear friends,

Good evening !

I so much need your help!! I usually use a lot of apps in Chinese. After setting my pebble back to factory mode, everything worked just fine until I found out that my pebble could not change language like it used to anymore… I followed the regular steps, but everytime when I tried the Setting- language settings- set language, the next page would tell “Something went wrong. You can change the language later from the Settings menu.” I tried multiple times and even reboot my phone for several times (My phone is moto g ), it seemed not helping at all… Now everything notification that I receive can’t show Chinese. Only the message in English shows normally…

I need your help! Please let me know if you have any suggestions or ways to solve this problem.

Thank you so much in advance and have a great day!

Best regards,

I can’t change my language anymore!

Think it is related to the server issues.


Oh no !! I hope the server will be back to normal as before soon… Pebble is such a good watch.


All is good again.


I had a similar problem. I downloaded language pack from here http://lp.getpebble.com/v1/languages