Watch faces gone forever?


#1

Hi all. My PTS lost its watch face so I went to app to upload it again. And there were only the two default watch faces available. I hit the + sign to add a new one and fit the list. Whenever I selected one or used search for my favourite (Aspire) I get Server Connection Issue. For a few days now. Is this the start of the full shutdown? Anybody else getting this problem? Thanks. David.


#2

I am not experiencing any problems with my Pebble or any of its faces. The watchface or watchapp might have been deleted by the person who made it. If you can, I recommend you contact the developer and ask them about it.


#3

I’m having the same issue … only have 2 default watchfaces and unable to add new ones. When I try to add any watchface, I get a message saying “Server connection issue”. Is anyone able to add new watchfaces? My guess is that the servers hosting these watchfaces are down … hopefully it’s temporary!


#4

Oh, my friend had that issue. I think it’s the phone unable to communicate with the server because my phone is okay.


#5

And my friend’s phone still gets the same error. It’s been around three months for him.


#6

This happened to my PTS a few months ago. I think it was caused when my watch rebooted when the Pebble App was loading…

In any event, here is how I fixed it:

  1. On your PTS, go to Settings > Bluetooth and Disconnect / Forget your phone.
  2. On the Phone, go into Settings > Bluetooth and Forget your PTS.
  3. Then UNLOAD the Pebble App
  4. Shutdown PTS
  5. Reboot phone
  6. Load the Pebble App, and check it is the latest version (do this BEFORE end of June)
  7. If necessary, download latest Pebble App
  8. Restart PTS, and go through regular pairing process
    Your stored watchFaces should be in the Pebble App

If this didn’t work, do again, but do a Factory Reset of your PTS at Step 4

PS: Check out PebbleJunkies.com for info of what will happen after Pebble Servers shut down.

Cheers!


#7

Thank you. That worked - pebble restored to former glory.

David