Hi @v ,I got no other tracker apps in my pebble , so uptempo is active when I install , by the way I have try restarting my pebble then install the app ,still can not work . I have try Misfit a period of time , found out the steps counts is completely inaccurate, Up watchface is good ,but the app always miss some data when transported to server .Finally I realize I just need something simple on my pebble , so I hope developer who with full of enthusiasm like you guys can may the pebble apps more reliable and useful , thanks for your concern :slight_smile:


I just got a Pebble watch today, so I am obviously new to it. I installed the Uptempo software but I cannot get it to work. So please, if someone could help me…WHERE CAN I FIND THE INSTRUCTIONS ON HOW TO USE IT!!! I have searched online and nothing, so this is becoming very frustrating!


Hi @v, uptempo is the only background app (as far as I can tell) , it’s the one set in Setting >Activity. I have tried deleting the App and reloading several times. I have tried using Misfit to make sure the watch itself is able to register movement and it works. What I haven’t tried yet is to do a factory reset and then reload the app. Will let you know how that goes.


@brimfeldt @“Shawn Su” , do let me know if you get it working. Meanwhile I have reset mine to see if I can replicate the problem. Are you both using Pebble Time or the original.
@brimfeldt, do both you and your husband have the same watch(Time or original)?
@Jamie, there are no instructions as such. Just install it and it should work. All the settings are accessed by clicking the middle button. Read th original post to read a bit more on how it works.


Hi @v ,I am using the original plastic Pebble :slight_smile:


Hi @“Shawn Su” @brimfeldt ,
I think the problem might be storage on pebble. Maybe some other app is using up the storage. What other apps are you using? Would it be possible to test UpTempo for a while without any other apps on the watch?
Edit: No need for this. This shouldn’t be the problem.


@v … SUCCESS! A factory reset did the trick! Woke this morning to find UpTempo had recorde 4h 23m sleep, which is not quite accurate but a least it’s not zero. :slight_smile: I’m still wearing my Vivosmart and the step count so far is pretty much the same, so we’re off to a great start. Thank you for your help.


@brimfeldt …Nice! Glad to see it’s working now.
@“Shawn Su”, can you also try resettinǵ the watch?


Hi v ,happy to find out after resetting the watch, uptempo begin to count steps , but I found that the alarm function did not work , I have set three different alarm , still can not work :o


@“Shawn Su” , for weekend and weekday alarms try not to set them less than an hour before they are supposed to ring. Also note that single alarm time is the time from now. So, 05:00 means 5 hours fom now, not 5 in the morning.


Bad news @v, Uptempo has stopped working :-(. Pebble ran out of power so I charged it over night and now all counters are all 0 still. Surely I don’t have to do a Factory reset after every recharge?! That wouldn’t make sense. Any other ideas?


@brimfeldt , are you sure it’s not just paused? With the last update if you start charging with the app open, it will pause itself. You can see the icon at the top right.


Hi @v , ignore the alarm problem , I unloaded the app then installed it again , the app stop working again , no steps count , I think I would like to wait for the official version,

v said:
@brimfeldt , are you sure it's not just paused? With the last update if you start charging with the app open, it will pause itself. You can see the icon at the top right.
Hi @v, no the app definitely wasn't paused. Just not counting and no Paused symbolic top right. I had noticed during the first iteration of this install on my watch that the Pause function seemed glitchy. It wouldn't stay off pause. i.e. The pause symbol appeared every time I entered the App from the watch face quick launch or the menu, even though I tried to turn it off multiple times. Whether this is contributing to the my issue only you can say. Anyway, for now I've reverted back to the Misfit app. Cheers


New update. Check original post to see what’s new in v0.12
@brimfeldt, @“Shawn Su”, would you like to test the new release to see if your issues have been resolved? The new release contains many bugfixes. I think your issues were caused by some combination of them. Unfortunately I can not test it for your issues myself as I did not face them.



Testing 0.13

Someway is not resetting sleep time. it’s adding I’ve now lot of sleeping time since last update.


Hi @“Francisco José García Inclán”, sorry for the late reply, I’m on vacation.
Version 0.12 had a bug that would not reset the values, 0.13 had the fix. Are you still having problem with that on version 0.13?


New update. Pebble Round now supported.


So far, pretty impressed with the app. It has all the features I was looking for. Step tracking, idle alerts, sleep tracking with smart alerts, all of that in a simple interface. Right now, i’ve only used for a day and one night. The sleep tracking seems accurate but, the step tracking seems very low compared to MisFit which usally tracked 2x more steps. I don’t know if this is because, I was less active today or, the step tracking algorithm is more strict. I’ll keep using this during the weekend and report my experiences after that time.


@Sam08 , hope you like it. And yes, it is more strict than misfit. It will not, for example, count steps while you are asleep. Though I do not think it should be twice as much. Do report how you find after a bit of use. Also, do let me know which watch you are using. Helps me keep track of experience on different watches.