Windows Phone 8 - Pebble App


#1282

Waiting for an update. Hope we can get notifications soon!


#1283

Unfortunately, no news yet. January through Mid-March are very busy for me each year.I am finally getting more time to work on the new app. I apologize for the delay. I know people are waiting…


#1284

@Andy Did you have any success in the end? I am having precisely the same problem as you.

Connected over normal BT (not LE)
PTR with firmware 3.10.1
PWP works fine
PTM doesn’t appear to be able to connect

When I tried the more recent version of PTM with the “association” function, every time I tried to associate the PTR, an error message would say that this had failed but when I next ran the app it would be shown as associated. Nothing else worked, however.


#1285

Matthew
I have been in contact with Rainier Mass (the author) by private email over the past couple of weeks and tested various versions. Latest version (20160327) associated successfully and indicated that it had communicated because it identified the latest firmware on the watch. However, when trying to connect, the same issues as before persist so it’s back into Rainier’s court. I’m not sure who will win the race - PTM or PWP but it’s nice to have two prongs of attack.


#1286

There are a few caveats here, however. For one, Windows Central says that all the app does is beam notifications from your device to your Pebble-clad wrist; there isn’t an app store or support for new watch faces. Oh and you need a developer unlocked phone to use it as well. In case you’re feeling adventurous, WC has a detailed description of how to make it all work.


#1287

I am currently using PTM from the developer site, not the store, and it works though it takes a few restarts to get it fully functioning. It will download apps and watch faces.


#1288

@Ian I couln’t get the connection working with the new version from March 27th - it is able to pair to the watch, but after that no connection can be established.
On the developer site it says it has experimental javascript support for weather watchfaces. Does this mean you can actually configure the watchfaces when you download them using PTM?


#1289
Rehban said:
@Ian I couln't get the connection working with the new version from March 27th - it is able to pair to the watch, but after that no connection can be established.
On the developer site it says it has experimental javascript support for weather watchfaces. Does this mean you can actually configure the watchfaces when you download them using PTM?

Ah - my version is pre-March 27th, so I don't know.

#1290

For clarity - I’m using 20160124


#1291

Ah, that explains it, thanks. The version from 20160124 works for me as well.


#1292

Thanks. I also got in touch with the PTM author and he’s a nice guy - over the weekend he updated his software and sent me a new version to test with my Round, but unfortunately it’s not working yet.

I bought the PTR (my first Pebble) just a few days ago and to be honest I’m really pleased with it even without proper notifications. It’s a bit galling to see what the iPhone and Android users are able to do with theirs and I look forward to having at least some of that functionality in the future.


#1293

And finally in 2016 … Access to notifications by all apps for Windows 10! (hopefully W10M before next year :wink: ).

https://channel9.msdn.com/Events/Build/2016/B803 (00:38)


#1294

A tale of experimentation.
I have a Pebble Steel and a Lumia 950xl.
I started with the MS notifications app. I wanted a newer firmware on the watch so bought PWP. That allowed me to update the firmware but did not give me background tasks.
Next I tried PTM. This gave me background tasks but doesn’t give firmware updates!
I posted earlier in this thread that I had trouble getting PTM to send Notifications. Another member suggested a few restarts solves the problem. It seemed to.
Yesterday I read the there was a beta of PTM so I decided to try it. I uninstalled the first version before experimenting.
I installed the beta but could not get Notifications working.
I went back to the earlier PTM but could not get a connection between phone and the watch.
I did a factory reset on the watch - I now know this resets to recovery firmware and so PTM would not connect!
Back to PWP to update the firmware.
I installed the non beta PTM. Initially I got no notifications. I tried a number of things including a few restarts. The one that seems to get Notifications running is turning ‘Notifications On’ in settings in the app. Closing PTM, restarting the phone. Setting ‘Notifications Off’ in settings in the app and restarting the phone, then repeat the first step again. I also restarted the watch.
Now I was back to where I had started!
However, today I again installed the beta PTM, this time over the top of the existing version. I went through the On/Off routine I document above and I now have the beta version working!


#1295

Thanks for the update @Ian !

How’s the functionality of the beta version of PTM? Does it update the weather functions of watchfaces as noted by the developer, and are watchfaces in any way configurable?


#1296
Rehban said:
Thanks for the update @Ian !

How's the functionality of the beta version of PTM? Does it update the weather functions of watchfaces as noted by the developer, and are watchfaces in any way configurable?

Haven't had much time to play yet. Weather is accessible from the timeline. I have some apps from the store that work, previously I struggled to find any.

#1297
Hi @Ian

I tried your method but no luck, even after many restarts with deactivating and reactivating notifications - when I first start PTM it asks me if I want to associate it to a pebble. It does find my pebble, but the association then fails. When I then try to connect, I get the message that the connection faild and "Element not found (Exception from HRESULT: 0x8007).

Are you able to connect in PTM using the green button? What does it say under settings about the associated pebble? I have my pebble there, but it only says "firmware" and no version...


#1298
Rehban said:
Hi @Ian

I tried your method but no luck, even after many restarts with deactivating and reactivating notifications - when I first start PTM it asks me if I want to associate it to a pebble. It does find my pebble, but the association then fails. When I then try to connect, I get the message that the connection faild and "Element not found (Exception from HRESULT: 0x8007).

Are you able to connect in PTM using the green button? What does it say under settings about the associated pebble? I have my pebble there, but it only says "firmware" and no version...


I was able to connect - until I did an upgrade to a beta version of Windows Phone (Insider Slow Ring). That stopped it working. As we speak I am rebuilding the phone back to an earlier version. PTM found the phone and associated it, but when I tried to connect I got a message telling me it couldn't start background notifications.

Edit - I rebuilt my phone back to Windows Insider Preview. Everything is working again. When I re-read my earlier post I notice that I missed a step. After each change I pressed the sync button on PTM.

#1299

FYI: I have just uploaded Pebble firmware 3.11.1 for all Pebble versions. You should be able to download and install it now from Pebble Watch Pro.


#1300

Installed 3.11.1 - can’t yet see anything different.


#1301
Ian said:
Installed 3.11.1 - can't yet see anything different.
A couple PWP users emailed asking when I would have it available. I didn't look for new features. I just checked it on a couple of different Pebbles then uploaded six different versions of the firmware so users could install it if they wanted to.